My HUAWEI computer cannot identify USB devices

Applicable products: PC,Desktop
Applicable products:
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My HUAWEI computer cannot identify USB devices

Problem

The HUAWEI computer cannot identify USB devices.

Cause

  • Third-party antivirus or manager software blocks USB devices.
  • The USB settings or connection is faulty.

Solution

Connect the USB device to another computer and check whether the device can be identified and used. If not, the USB device is faulty. Contact the USB device vendor. If yes, perform the following steps to locate the fault.

  1. Check the connection status of the USB device.
    1. The port size of different USB devices may be different, and they may not be fully connected to the computer. In this case, you can pull out the USB device slightly to fully connect it to the computer. You can try this method for a USB device that has a size deviation. The computer may not respond if you have incorrectly plugged the external device into the computer. To resolve this, plug the device into the computer again and check whether this issue has been resolved. Alternatively, plug the device to another USB port of the computer. The sizes of some USB ports on external devices are not standard and may not fit into the USB port on your computer.
    2. If you are using a portable hard disk, connect the docking station to a power cable, and then connect the portable hard disk to the docking station to check whether the issue is caused by power supply problems.
  2. Uninstall the USB Mass Storage Device from the computer, remove and insert the USB device again, and check whether the issue is resolved. (Uninstallation steps: Right-click the Windows icon and open Device administrator. Click to expand Universal Serial Bus controllers, right-click USB Mass Storage Device, and select Uninstall device from the shortcut menu.)

  3. You can also uninstall and reinstall the serial port driver as follows: Open Device Manager, click to expand Universal Serial Bus controllers, right-click USB root hub (usb3.0), and choose Uninstall from the shortcut menu. Then, right-click Universal Serial Bus controller again, and click Scan to detect hardware changes. Disconnect the power supply and all external devices. Press and hold the Power button for 10 seconds, restart the computer, and reconnect the external device.
  4. Set USB selective suspend setting to Disabled. To do this, perform the following:
    1. Enter Control Panel in the search box on the taskbar and open it, choose to view by Small icons, and select Power Options.

    2. Click Change plan settings.

    3. Click Change advanced power settings.

    4. Expand USB settings > USB selective suspend setting, and set both On battery and Plugged in to Disabled. Then, click OK.

  5. Format the USB device.

    Formatting a USB device will cause data loss. To prevent data loss, back up data on the device before resetting the device.

    1. Enter File Explorer in the search box on the taskbar and open it. Right-click the drive letter and select Format from the shortcut menu.
    2. Keep the default settings and then click Start to proceed to the next step.
    3. Wait until a dialog box is displayed, indicating that the formatting has been completed.

If none of your USB devices can be identified, check the USB port settings on the computer's BIOS settings screen.

  1. During startup or restart, press and hold or press F2 consecutively to enter the BIOS settings screen. Check whether the USB Port Enable item exists.
    • If not, skip this step.
    • If USB Port Enable is enabled, skip this step.
    • If USB Port Enable is disabled, enable it.

  2. On the BIOS settings screen, press F9 to restore the BIOS Default Settings, click OK, and press F10 to save the settings. The USB port is enabled by default in the initial BIOS settings.
  3. If the issue persists, switch the BIOS language to Chinese by referring to Changing the BIOS language and try again.

If the issue persists

If the issue persists, back up your data, record your Office account, and use F10 to restore your computer to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center. We will do our best to address your needs.

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