Não é possível instalar o controlador da impressora ou utilizar a impressora depois de ter instalado o controlador da impressora
Não é possível instalar o controlador da impressora ou utilizar a impressora depois de ter instalado o controlador da impressora |
Problema
O utilizador tenta ligar uma impressora ao computador, mas não funciona. Podem ocorrer os seguintes problemas: a impressora não responde quando está ligada ao computador; aparece um ponto de exclamação amarelo no ícone da impressora no Gestor de Dispositivos depois de a impressora ter sido ligada ao computador; o controlador da impressora não pode ser instalado; a impressora não funciona corretamente; a impressora não é listada depois de o controlador da impressora ter sido instalado.
Causa
Estas são as possíveis causas: o controlador da impressora é anexado ao pacote como um CD-ROM mas o computador não vem com uma unidade de CD-ROM; a versão do controlador transferido da Internet é incompatível com o sistema; as definições para adicionar uma impressora no painel de controlo estão incorretas.
Solução
Transfira e instale o controlador da impressora e, em seguida, configure corretamente a impressora.
Método 1:
- Aceda ao website oficial da marca da impressora e transferir o controlador do modelo de impressora correspondente. Utilizando uma HP LaserJet Pro P1106 como exemplo, visite o website oficial da HP, aceda a Suporte > Impressão, introduza o modelo da impressora, e transfira o controlador correspondente.
- Descomprima o controlador da impressora transferido.
- Clique com o botão direito do rato no ambiente de trabalho e selecione Gerir no menu de atalho.
- Na lista à esquerda, selecione Serviços e aplicações e clique duas vezes em Serviços.
- Clique duas vezes em Spooler de Impressão, defina o tipo de arranque para Automático e clique em Iniciar e OK.
Nota: se o sistema exibir uma mensagem com um código de erro indicando que o serviço Spooler de Impressão não pode ser iniciado devido a recursos insuficientes, introduza “cmd” na caixa de pesquisa na barra de tarefas, clique com o botão direito do rato na aplicação, e selecione Executar como administrador a partir do menu de atalho. Na caixa de diálogo de comandos apresentada, introduza “netsh winsock reset” e prima a tecla Enter. Em seguida, reinicie o computador. Isto repõe a rede do computador. Pode ter de introduzir novamente a palavra-passe para se ligar à rede anterior. A VPN, a impressora ligada ou LAN ligada só podem ser utilizadas depois de configuradas novamente.
- Selecione Extensões e Notificações da Impressora, clique em Mais Ações no lado direito, e selecione Iniciar. (Se esta opção não estiver disponível, ignore este passo.)
- Selecione PrintWorkflowUserSvc, clique em Mais Ações no lado direito, e selecione Iniciar. (Se esta opção não estiver disponível, ignore este passo.)
- Selecione Servidor, clique em Mais Ações no lado direito, e selecione Iniciar.
- Volte ao ambiente de trabalho e clique duas vezes no programa de configuração no pacote do controlador descomprimido.
- Selecione Instalação simples e clique em Seguinte.
- Selecione o modelo da impressora e clique em Seguinte.
- Ligue a impressora ao computador através de um cabo USB, conforme necessário, e ligue a impressora.
- Depois de instalada a impressora, clique em Seguinte e reinicie o computador. Se não for possível instalar o controlador, recomenda-se que atualize o controlador da porta de série.
Depois de concluído o reinício, podem ocorrer as seguintes situações:
O controlador foi instalado, mas o painel de controlo não identifica automaticamente a impressora. Neste caso, é necessário adicionar manualmente a impressora.
Execute os seguintes passos:
- Clique no ícone do Windows e aceda a Definições > Dispositivos.
- Selecione Impressoras e scanners e clique em Adicionar uma impressora ou um scanner.
- Se a impressora não for detetada, clique em A impressora que pretendo não se encontra listada.
- Selecione Adicionar uma impressora local ou impressora de rede com definições manuais, clique em Seguinte, selecione Utilizar uma porta existente ou Criar uma nova porta e clique em Seguinte.
- Clique em Disco....
- Localize a pasta do controlador descomprimido gerada depois de o controlador ter sido transferido do website oficial da impressora, selecione o ficheiro .inf correspondente (geralmente com o nome do modelo ou série da impressora), e clique em Abrir.
- Clique em OK.
- Selecione Não partilhar esta impressora. (Para partilhar esta impressora, introduza o endereço LAN correto.)
- Clique em Imprimir página de teste e, em seguida, em Concluir.
A instalação do controlador falha. Neste caso, é necessário adicionar manualmente o controlador.
Abra o Gestor de Dispositivos e localize a impressora. Se um ponto de exclamação amarelo for exibido no ícone da impressora, clique com o botão direito do rato na impressora e selecione Atualizar controlador a partir do menu de atalho.
Nota:
se a instalação demorar muito tempo ou se o utilizador repetir a instalação várias vezes, será exibida uma mensagem indicando que a instalação falhou. Neste caso, desligue o cabo USB, localize a pasta do controlador descomprimido, e execute uninstall.exe na pasta. Após a desinstalação do controlador, reinicie o computador e reinstale o controlador. Depois, utilize o cabo USB para ligar a impressora ao computador, conforme solicitado.