Porque não se pode fazer pagamentos em aplicações/renovar serviços de subscrição automaticamente para aplicações transferidas a partir da HUAWEIAppGallery?
Porque não se pode fazer pagamentos em aplicações/renovar serviços de subscrição automaticamente para aplicações transferidas a partir da HUAWEIAppGallery? |
Problema:
- Falha de pagamento: Um pagamento em aplicação falhou, mas não existe mensagem de erro a indicar a razão.
- Serviço de subscrição: As subscrições ativas não podem ser renovadas automaticamente.
Causa:
Se uma aplicação/jogo não for distribuído na região de serviço que definiu para o cliente da sua HUAWEIAppGallery, não poderá realizar pagamentos nele, mas os serviços de aplicação/jogo comprados anteriormente ainda serão válidos. Quanto aos serviços de subscrição, estes irão expirar assim que o período de subscrição atual expirar e não podem ser renovados automaticamente.
Solução:
1. Atualize o HMS Core (Huawei Mobile Services) para a versão mais recente. Se a aplicação em questão não for distribuída na região de serviço que definiu para o seu cliente da HUAWEIAppGallery, o sistema irá apresentar uma mensagem a indicar a causa da falha quando o pagamento falha.
2. Aceda a
, altere a área de serviço para o país/região onde transferiu a aplicação em questão. Posto isto, poderá efetuar pagamentos e ativar as renovações automáticas para a aplicação.