É apresentada uma caixa de diálogo a indicar que existe um erro de rede quando utilizo o HUAWEI Mobile App Engine |
Problema
Quando o utilizador utiliza o HUAWEI Mobile App Engine para executar uma aplicação móvel, é apresentada uma caixa de diálogo a indicar que existe um erro de rede.
Causa
- Existe um problema com a rede do computador.
- O HUAWEI Mobile App Engine está restrito pela rede atual.
- Uma aplicação no HUAWEI Mobile App Engine não consegue aceder à Internet.
Solução
Solução 1: se existir um problema com a rede do computador:
Proceda à resolução do problema consultando as informações em https://consumer.huawei.com/en/support/content/pt-pt00692618/.
Solução 2: se o HUAWEI Mobile App Engine estiver restrito pela rede atual:
Siga os passos abaixo para resolver o problema:
1. Verifique se a rede atual é uma rede pertencente a uma escola ou empresa. Em caso afirmativo, mude para uma rede normal (tal como a de um ponto de acesso de telemóvel) e tente novamente.
2. Verifique se está ativada uma proxy de rede ou uma VPN. Em caso afirmativo, desative a proxy ou a VPN.
Para o fazer, execute os seguintes passos:
No computador, aceda a Definições > Rede e Internet.
2. Clique em Proxy.
Certifique-se de que as opções Detetar definições automaticamente e Utilizar um servidor proxy estão desligadas.
3. Verifique se o computador está ligado apenas a uma rede IPv6.
Para o fazer, execute os seguintes passos:
Abra o navegador e introduza test-ipv6.com na barra de endereços. Se o endereço puder ser aberto e o resultado do teste mostrar que o computador está ligado a uma rede IPv6 mas não a uma rede IPv4, isto indica que o computador só está ligado a uma rede IPv6. Verifique se o computador e o router estão ligados a uma rede IPv4.
Ligue o computador a uma rede IPv4 executando os passos abaixo:
No computador, aceda a Definições > Rede e Internet.
Clique em Definições avançadas de rede para alterar os adaptadores de rede.
Clique com o botão direito do rato no adaptador de rede atual e selecione Propriedades no menu apresentado.
No ecrã Propriedades da WLAN apresentado, verifique se a opção IPv4 está selecionada e se a configuração é válida.
Se o computador já se tiver ligado a uma rede IPv4, verifique as definições do router. Para mais detalhes sobre como verificar se o router está ligado a uma rede IPv4, contacte o fornecedor do router para verificar as definições do mesmo e assegurar-se de que o router está devidamente ligado a uma rede IPv4.
4. Se o problema continuar, desative e depois reinicie o HUAWEI Mobile App Engine, ou reinicie o computador e tente novamente.
Para terminar a tarefa do HUAWEI Mobile App Engine, execute os seguintes passos:
Abra o Gestor de Tarefas, selecione HUAWEI MobileApp Engine e, em seguida, clique em Terminar tarefa, conforme ilustrado na figura abaixo.
Em seguida, clique em HUAWEI MobileApp Engine para o reiniciar.
5. Se o problema continuar, crie uma cópia de segurança dos seus dados e leve o dispositivo, juntamente com a respetiva prova de compra, a um Centro de Assistência Técnica Huawei autorizado para obter assistência.
Solução 3: se uma aplicação no HUAWEI Mobile App Engine não conseguir aceder à Internet:
1. Reinstale a aplicação móvel e tente novamente. Para isso, efetue o seguinte:
Método 1: aceda a Definições > Aplicações e funcionalidades, selecione a aplicação móvel a ser desinstalada e selecione Desinstalar.
Método 2: aceda a Eu na HUAWEI AppGallery, clique com o botão direito do rato na aplicação móvel a ser desinstalada e selecione Desinstalar.
2. Se o problema continuar, contacte o apoio ao cliente da Huawei e forneça o nome da aplicação. A Huawei pedirá aos programadores desta aplicação para resolver este problema.