The touchscreen on my HUAWEI phone/tablet doesn't respond or responds slowly

Applicable products: Tablet,Smartphone
Applicable products:
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The touchscreen on my HUAWEI phone/tablet doesn't respond or responds slowly

Problem:

The phone/tablet screen sometimes responds slowly or does not respond to touch control.

Cause:

  • The screen touch control settings are incorrect, or Ignore repeated touches is enabled.
  • The issue may lie with third-party apps.
  • The screen has smudges or water stains.
  • A network error occurs.
  • The device's temperature is too high or low.
  • The charger is not a standard charger.

Solution:

  1. You are advised to disable Ignore repeated touches and set Tap duration/Touch & hold duration to Short. The path is as follows:

    Settings > Accessibility features > Accessibility > Touchscreen settings.

  2. You can check whether the issue is caused by a third-party app or software as follows:

    1. Enable Show taps and Pointer location.

    To do so, go to Settings > About phone > EMUI version (tap 7 times consecutively) > System & updates > Developer options.

    2. Swipe or tap the screen with your finger, and check whether there is a white dot and a line on the screen. If there is a white dot and a line and the line is consistent, the issue is caused by a third-party app or software issue. Please wait for a system update or app update.

  3. Clean and dry the screen before proceeding.
  4. Use your device in a good network environment or connect your device to a Wi-Fi network.
  5. Close the apps running in the background and wait until the device's temperature goes back to normal before using your device again.
  6. If the issue only occurs when you are using a third-party charger or charging the device in a fixed place, it is recommended that you use a HUAWEI charger or charge the device in another place (with a different power supply).
  7. If the screen does not respond, press and hold the Power button for more than 15 seconds, or press and hold the Volume down and Power buttons simultaneously for more than 10 seconds, to forcibly restart your device.

If the issue persists, back up your data and take your phone/tablet, standard charger, data cable, and proof of purchase to an authorized Huawei Customer Service Center for assistance.

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