Unable to enable or disable Wi-Fi on my HUAWEI phone/tablet
Unable to enable or disable Wi-Fi on my HUAWEI phone/tablet |
Problem:
The Wi-Fi switch or other switches cannot be turned on or off on the HUAWEI phone/tablet.
Cause:
This may be caused by related settings or other management and control apps.
Solution:
- Enable and disable Airplane mode and restart your phone/tablet.
Enable and then disable Airplane mode, restart your phone/tablet, and check whether Wi-Fi is enabled.
- Turn on the switch for allowing system settings to be modified in Settings.
Open Settings, search for and select Apps, then search for and select Settings. Touch Modify system settings and turn on the switch. (If this option is unavailable, skip this step.) If the permission to modify system settings in Settings has not been granted, you cannot turn the hotspot switch on the hotspot settings screen on or off as the screen will exit.
- Check whether a security control app has been installed on your phone/tablet.
Open Settings and go to Security > More settings > Device administrators to check whether there are active apps with the set up the WLAN permission. If so, deactivate the app and try again.
If there is no switch for modifying the system settings or there is no security control app on your phone after your phone has been updated to HarmonyOS NEXT, perform the following.
- Reset your network settings.
Open Settings, enter Restore network settings in the search box at the top, and touch to restore the network settings of the phone/tablet.
This operation will restore all network settings, including Wi-Fi, mobile data, and Bluetooth settings.
If the issue persists, the hardware of your phone/tablet may be faulty. Back up your data in advance, and take your device and proof of purchase to a nearby Huawei Customer Service Centre for assistance.