The step count data from a third-party app is inaccurate on my HUAWEI phone

Applicable products: Smartphone
Applicable system: EMUI 10.0.1, EMUI 10.1.1, EMUI 14.2, EMUI 5.0, EMUI 9.1.1, EMUI 5.1, EMUI 9.0.1, EMUI 8.0, EMUI 8.1, EMUI 9.0, EMUI 8.2, EMUI 9.1, EMUI 10.0, EMUI 11.0, EMUI 10.1, HarmonyOS 3.1, HarmonyOS 4.0, HarmonyOS 4.2, Magic UI 3.0.1, Magic UI 3.1.1, HarmonyOS 3.0, Magic UI 2.0, Magic UI 2.0.1, Magic UI 3.0, Magic UI 2.1, Magic UI 2.1.1, Magic UI 4.0, Magic UI 3.1, HarmonyOS 2.0
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The step count data from a third-party app is inaccurate on my HUAWEI phone

Problem:

On HUAWEI phones that support the step count feature, a third-party health app does not count steps, counts steps inaccurately, or tracks the user's workout route inaccurately.

Cause:

The app in question may have been cleared by your phone when it was running in the background.

Solution:

Update the app to the latest version and keep it running in the background.

  1. Enable Run in background for the app.

    Open Settings on your phone, search for and access Launch, set the app to be managed manually by disabling Manage automatically for the app, and select Auto-launch, Secondary launch, and Run in background in the pop-up box.

  2. Enable Ignore battery optimisation for the app.
    • EMUI 9.X and later: Open Settings, and search for and access Battery optimisation. Touch the small inverted triangle next to Don't allow, touch All apps, locate and touch the app, and select Don't allow.

  3. Disable Power saving mode.

    Go to Settings > Battery, and disable Power saving mode and Ultra power saving mode.

  4. Lock the app on the Recent tasks screen.

    On the Recent tasks screen, locate the app in question, and swipe down on it or touch . When is displayed in the upper right corner of the app, it means that the app has been locked on the Recent tasks screen.

If the issue persists or you encounter any difficulties while doing this, please call the Huawei customer service hotline for assistance.

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