Unable to connect my computer to the network
Applicable products: PC,Desktop
Applicable system: Windows 10, Windows 11
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Unable to connect my computer to the network

Problem

The computer cannot connect to the Wi-Fi hotspot or access the Internet.

Cause

  1. There is an issue with the random hardware address of the Windows 10 system.
  2. There is an issue with the Wi-Fi hotspot because other devices cannot connect to this Wi-Fi network as well.
  3. Some parameters of the network system may have been tampered with due to software conflicts or viruses.
  4. This occurs because the wireless network adapter driver is lost or an unofficial driver has been installed.

Solution

Perform the following to troubleshoot:

Method 1: Uninstall the third-party manager software and disable the Wi-Fi random hardware address feature.

  1. Uninstall third-party manager software, such as Tencent Manager, 360 Manager, and Kingsoft Antivirus.
  2. Perform the following to disable the Wi-Fi random hardware address feature.
    1. Enter "Wi-Fi" in the search box and open Wi-Fi settings.
    2. Disable Random hardware address.
  3. Disconnect the computer from the power supply. Press and hold the power button for 15 seconds then power on the computer again.
Method 2: Connect your phone or other devices to the Wi-Fi to check whether your Wi-Fi is working properly.
  • If you can connect another device to the Wi-Fi, it indicates that there is not an issue with the network. Restart your computer and connect it to the Wi-Fi and check whether this issue is resolved.
  • If you cannot connect another device to the Wi-Fi, it indicates that there is an issue with the network. Restart your router and try again.
Method 3: If the issue has been caused by a software conflict or computer virus, reset your computer configurations. Please remember the password of the network before resetting the network.
  1. Enter cmd in the search box on the taskbar.
  2. Right-click Command Prompt and select Run as administrator.
  3. Enter netsh winsock reset and press Enter.
  4. Restart your computer and connect to the Wi-Fi.

Method 4: Check whether the Wi-Fi driver is working properly.

  1. Right-click the Windows icon.
  2. Click Device Manager.
  3. Expand Network adapters.
  4. Check whether Intel® Wireless-AC XXXX is included.
    • If not, press and hold the power button for 10 seconds to force shut down your computer and then restart it again.
    • If a yellow exclamation mark is displayed before Intel® Wireless-AC XXXX, update your Wi-Fi driver and restart your computer. There are two ways to update the network adapter: 1. Install the latest version of the network adapter via the official website. 2. Install the latest version of the network adapter using PC Manager.

      Check whether you can connect the computer to the Internet using a wired network or USB shared network. Then perform the following to troubleshoot.

Note: For computers that run on the AMD platform, the network adapter will be displayed as "Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC". For HUAWEI MateBook E 2019, the network adapter will be displayed as "Qualcomm (R)wi-fi B/G/N/AC(2X2)SVc".

Method 5: If the issue persists, back up your data, press F10 consecutively or hold F10 when powering on the computer to reset the system, or take your device and proof of purchase to an authorised Huawei Customer Service Centre for assistance.

Restoring your system to the factory settings will clear all your data in the C drive. Back up any important data before you proceed.

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