The computer can't be detected by my phone to use Miracast
| The computer can't be detected by my phone to use Miracast |
Problem
When Miracast is used to project a phone screen to the computer, the phone cannot detect the computer.
Miracast helps to project a phone screen to a computer screen.
Cause
When Miracast is used to project a phone screen to a computer screen, Windows 10 will automatically select a 2.4 GHz or 5 GHz WLAN channel based on the current environment. Single-band phones support only 2.4 GHz WLAN channels, while dual-band phones support both 2.4 GHz and 5 GHz WLAN channels.
If you are using a single-band phone and the 5 GHz WLAN channel is selected, the computer cannot be detected.
It is recommended that you use a dual-band phone and a computer for wireless projection using Miracast.
Solution
- Press Win+I to access the Windows Settings screen.

- Go to Network & Internet > Wi-Fi > Change adapter options.

- Right-click Wi-Fi and go to Properties > Configure... > Advanced. In the displayed dialog box, select Preferred Band and set the value to 2. Prefer 2.4GHz band.

