When I try to transfer files using Huawei Share OneHop, the computer displays a loading circle and a yellow exclamation mark, and the phone displays a message indicating that the file transfer has failed

Applicable products: HUAWEI MateStation X,PC
Applicable system: Windows 10, Windows 11
Applicable products:
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When I try to transfer files using Huawei Share OneHop, the computer displays a loading circle and a yellow exclamation mark, and the phone displays a message indicating that the file transfer has failed

Problem

There is a loading circle or a yellow exclamation mark on the computer, or there is no response or the phone displays a message indicating that the file transfer has failed when the user tries to use Huawei Share OneHop to transfer images, videos, and documents.

Cause

  1. This may happen because the version of PC Manager on your computer is too early, or PC Manager is faulty.
  2. This may happen because of the Wi-Fi P2P pairing failure when the transmission channel is established between the phone and the computer.
  3. This happens because you may use the wrong method to open images, videos, or files.
  4. There is an issue with Huawei Share on your phone.
  5. The firewall on the computer is abnormal.

Solution

Check point 1: This may happen because the version of PC Manager on your computer is early, or PC Manager is faulty.

Solution:

  1. Visit the official website of the computer model to check whether you are using the latest version of PC Manager on your computer.

    If you are using a HUAWEI computer, please refer to http://consumer.huawei.com/en/support/index.htm.

    If you are using an HONOR computer, please refer to https://www.hihonor.com/global/support/.

  2. Uninstall PC Manager, and reinstall it again.

Check point 2: The Wi-Fi of the computer and the phone is faulty.

Solution:

  1. Restart the virtual adapter on your computer.
    1. Right-click the Windows icon, go to Device Manager > View > Show hidden devices, expand Network adapters, right-click the device, and click Disable device.

    2. Right-click Microsoft Wi-Fi Direct Virtual Adapter, and select Enable device.

    3. Then right-click Microsoft Wi-Fi Direct Virtual Adapter, select Properties, and check whether the network adapter is working.

  2. Visit the official website and download the latest version of the Wi-Fi driver.
    • If you are using a HUAWEI computer, please refer to https://consumer.huawei.com/en/support/product/?tag=mate-book&u=u/.
    • If you are using an HONOR computer, please refer to https://www.hihonor.com/global/support.

    a. Download the latest version of the Wi-Fi driver on your computer.

    b. Expand Network adapters, right-click the Wi-Fi driver, and choose Uninstall device. Check the box next to Delete the driver software for this device, and click Uninstall. Return to the default downloading path, and double-click the .exe file to install the driver.

    Note: The Wi-Fi driver of the AMD-based computer is Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC. For the HUAWEI MateBook E 2019, the network adapter will be displayed as Qualcomm(R) wi-fi B/G/N/AC(2X2)SVc.

  3. This is due to an issue with Wi-Fi on the phone.
    1. To restore the network settings on your phone, go to Settings > System & updates > Reset > Reset network settings. (If there are two cards on your phone, reset network settings for one of the cards.)

      Note: Resetting network settings will restore the Wi-Fi, mobile data, and Bluetooth (such as Hotspot connectivity data and Bluetooth pairing data) settings.

    2. Restart your phone.
    3. Update your phone to the latest EMUI version.

Check point 3: You may not be using the correct method to open images, videos, or documents.

Solution:

  1. Use Huawei Image Viewer or Photos that is preinstalled in the Windows system to open images on the computer.
  2. Use Huawei Image Viewer to open videos on your computer.
  3. Use Gallery or WPS to open files on your phone.

Check point 4: There is an issue with Huawei Share on your phone. In this case, clear the cache of Huawei Share on your phone.

Solution:

On your phone, go to Settings > Apps > Apps, touch the three-dot icon in the top-right corner, and then go to Show system processes > Huawei Share > Storage > CLEAR CACHE.

Check point 5: There is an issue with the firewall. Reset the firewall to resolve this issue.

Solution:

  1. Enter "Settings" in the search box in the bottom-right corner, and open Settings.

  2. Select Update & Security.

  3. Select Windows Security and then Firewall & network protection.

  4. Select Restore firewalls to default.

If the issue persists, back up any important data on the C drive (Desktop, Downloads, and Documents) then use F10 to restore your computer to its factory settings.

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