Unable to find the Wi-Fi icon in the bottom-right corner on the taskbar of my computer
Applicable products: PC,Desktop
Applicable system: Windows 10, Windows 11
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Unable to find the Wi-Fi icon in the bottom-right corner on the taskbar of my computer

Problem

There is no Wi-Fi icon in the bottom-right corner on the taskbar of the computer.

Cause

This may happen because the registry list related to the network has been deleted or modified, resulting in the network icon disappearing or being hidden.

Solution

  1. Check whether you are connected to a campus network and have installed NetKeeper. If so, refer to http://consumer-tkb.huawei.com/weknow/index.html#!a/detail.html?contextNo=zh-cn00706777.
  2. Otherwise, check whether the network icon has been hidden. To do this, perform the following:

    The page varies depending on the OS. The actual page prevails.

    1. Right-click the taskbar and click Taskbar settings.

    2. Swipe down on the Taskbar screen to the Notification area, then click Turn system icons on or off.

    3. Check whether Network has been turned off.

  3. Check whether you can connect the computer to the Internet using a wired network or USB tethering. For example, you can enable USB tethering on your phone and connect your phone to your computer. Then perform the following steps:
    1. Disconnect the computer from the power supply and press and hold the Power button for 10 seconds to restart the computer.
    2. If the issue persists, right-click the Windows icon and then the Settings icon, go to Device Manager > Network adapters, right-click Intel(R) Wireless-AC 9560 then click Disable device. Right-click Intel(R) Wireless-AC 9560 again and click Enable device.

    Note: The Wi-Fi driver of the AMD-based computer is Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC.

  4. On other computers that support network access, download the network adapter driver from the Huawei/Honor official website, copy the driver to the computer using a USB flash drive, and then reinstall the network adapter driver to try again.
  5. If the issue persists, back up your important data, restart your computer, and press and hold F10 or press F10 consecutively multiple times to restore the computer to its factory settings.

Please note that restoring the computer to its factory settings will clear all data in the C drive, including personal files downloaded in Desktop, Downloads, and Documents. Please back up any important data on the C drive before restoring the computer to its factory settings. If the issue persists, back up data and bring your computer and proof of purchase to a nearby Huawei Customer Service Centre for assistance.

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