After my computer is connected to the hotspot, the Wi-Fi icon is displayed as connected, but the network is unavailable or low-responded |
Problem
After the computer is connected to the hotspot, the Wi-Fi icon is displayed as connected, but the network is unavailable or low-responded.
Cause
This may be because a system file has been modified.
Solution
This may happen when the system configuration has been modified due to third-party apps. In this case, you can set the Value of MIMO Power Save Mode to No SMPS or set Power Saving Mode to Maximum Performance. (Please note that this is only applicable to computer models with the Intel network card chip.) Perform the following steps to troubleshoot the issue based on your specific case:
Method 1: If you are not using a VPN on your computer, perform the following steps:
- Reset the network, by going to Start > Settings > Network & Internet > Status > Network reset. Resetting the network will cause the Wi-Fi password to be lost. In this case, you'll need to enter the password again to connect to the Wi-Fi network.
After you reset the network, perform the following steps to modify the configuration.
- Set the Value of MIMO Power Save Mode to No SMPS.
- Click the Wi-Fi icon and go to Network & Internet settings > Network and Sharing Centre > Change adapter settings.
- Right-click Wi-Fi and then Properties, then click Configure....
- Click Properties, select Advanced, click MIMO Power Save Mode, set Value to No SMPS, then click OK.
- Click the Wi-Fi icon and go to Network & Internet settings > Network and Sharing Centre > Change adapter settings.
- To enhance the receptivity of computer, set Power Saving Mode to Maximum Performance in Power Options, by performing the following steps:
- Open Control Panel, go to Hardware and Sound, and select Power Options.
- Click Change plan settings.
- Click Change advanced power settings.
- Click Wireless Adapter Settings, select Power Saving Mode, and set On battery and Plugged in to Maximum Performance.
- Open Control Panel, go to Hardware and Sound, and select Power Options.
Method 2: If you are using a VPN but cannot access the network, you'll need to restore the VPN settings or proxy server to default, clear forcibly modified configurations, or change the firewall settings or UAC settings level of the Windows system. Perform the following steps:
- Go to Start > Settings > Network & Internet > Proxy, and manually set the two items shown in the following figure.
- Go to Internet Explorer > Tools > Internet Options, click Connections, and delete all items in Dial-up and Virtual Private Network settings. Then click LAN settings, select Automatically detect settings, and click OK.
- Open Control Panel, go to System and Security > Action Centre > Change User Account Control Settings, select Never notify, then click OK.
- Open Control Panel, go to System and Security > Windows Defender Firewall with Advanced Security on Local Computer > Properties, then set Firewall state to Off under Domain Profile, Private Profile, and Public Profile.
- If the issue persists, contact the VPN provider for assistance.