My computer is unable to search for or connect to the hotspot
Applicable products: PC,Desktop
Applicable system: Windows 10, Windows 11
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My computer is unable to search for or connect to the hotspot

Problem 1

The computer is unable to search for or connect to the hotspot.

Problem 2

The computer is unable to connect to the hotspot or any other network, or frequently disconnects from the network.

Cause

There are discrepancies between the system refresh interval, architecture driver refresh interval, and the hotspot refresh interval, resulting in it taking more time for the computer to search for the hotspot. The computer may also be incompatible with certain hotspots.

Solution 1

  1. If your computer cannot search for the hotspot, restart the router, then disable and enable the Wi-Fi driver. Perform the following steps:
    1. Click the Wi-Fi icon and go to Network & Internet settings > Network and Sharing Centre > Change adapter settings.

      Right-click Wi-Fi, click Disable device, and then right-click Wi-Fi again, and click Enable device.

    2. Set MIMO Power Save Mode to No SMPS. (Please note that this is only applicable to computer models with the Intel network card chip.)
      1. Click the Wi-Fi icon and go to Network & Internet settings > Network and Sharing Centre > Change adapter settings.

      2. Right-click Wi-Fi, click Properties, and click Configure....

      3. Click Properties, select Advanced, click MIMO Power Save Mode, set Value to No SMPS, then click OK. (Note: This step will disconnect the network.)

Solution 2

If your computer is unable to connect to the hotspot or any other network, or frequently disconnects from the network, perform the following steps:
  1. Click the Wi-Fi icon in the bottom-right corner on the taskbar, go to Network & Internet settings > Wi-Fi > Manage known networks, select the hotspot, and click Forget. Then reconnect your computer to the hotspot and enter the correct password.

    Note: To check whether you have been entering the correct password, select the option to forget the password of the Wi-Fi connection on your phone or other devices, then enter the password again.

  2. If you are sure that you have entered the correct password, but your computer still frequently disconnects from the network, check whether your computer can establish a connection with a phone hotspot or other wireless routers. If so, it may be because you are using an old router. Perform the steps mentioned in Step c. If the issue persists, replace the router with a new one.
  3. Set MIMO Power Save Mode of the Wi-Fi to No SMPS. For details, see item b in Solution 1.
  4. To enhance the receptivity of computer, set Power Saving Mode to Maximum Performance in Power Options, by performing the following steps:
    1. Open Control Panel, go to Hardware and Sound, and select Power Options.

    2. Click Change plan settings.

    3. Click Change advanced power settings.

    4. Click Wireless Adapter Settings, select Power Saving Mode, and set On battery and Plugged in to Maximum Performance.

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