Unable to control smart home devices in Control Panel when my Huawei phone/tablet is connected to a mobile network
Applicable products: Tablet,Smartphone
Applicable system: HarmonyOS 3.0, HarmonyOS 2.0, HarmonyOS 2.0.1
Applicable products:
Applicable system:
These are your search results, please select one
No results found, please select again
zoom in pic
Unable to control smart home devices in Control Panel when my Huawei phone/tablet is connected to a mobile network

Problem:

When the phone/tablet is connected to a mobile network, the user cannot control smart home devices in Control Panel and a message is displayed indicating that devices failed to be controlled.

Cause:

Smart data saver is enabled on the phone/tablet, resulting in AI Life Service not being able to access the Internet.

Solution:

Go to Phone Manager > Mobile data > Smart data saver, touch the four-dot icon () in the top-right corner, select Show system processes, search for the keyword "AI" in the EXEMPTIONS list, and locate AI Life Service and enable it.

Helpful or not?
Thanks for your feedback.