Issues related to HUAWEI ID country/region changing
| Issues related to HUAWEI ID country/region changing |
Problem 1
When the user goes to and tries to change the country/region, the message "You can change your country/region a maximum of 20 times in a 90-day period." is displayed. When the number of country/region changes reaches the upper limit, the message "You've changed your country/region 20 times in the last 90 days. Further changes are temporarily restricted." is displayed.
Cause
- You can change your country/region only after moving to a new country/region.
- Frequent changes of country/region may cause issues with your balance, subscriptions, and purchased content. To ensure your data stability and property security, we need this period to properly process all associated information.
- When you change the country/region of your account, you need to link a payment method in the new country/region and clear the card linking data in the original country/region. Frequent changes may be identified as abnormal operations by the bank risk system, which may cause your bank card to be unavailable. Therefore, there is a limit on the number of times that you can change the HUAWEI ID service location for which a bank card has been linked.
Solution
1. If the number of changes reaches the upper limit, you need to wait until the restriction time expires before changing the country/region again.
2. You can also register a new HUAWEI ID in the target country/region.
3. If you wish to change the country/region of your HUAWEI ID to access apps in another country/region, please refer to the third point in Unable to change the country/region in AppGallery.
Problem 2
When the user goes to and tries to change the country/region of their HUAWEI ID, the system asks them to link a bank card (payment method).
Cause
- You can change your country/region only after moving to a new country/region.
- Linking a local payment method is one way to verify your valid identity in the new country/region. This will effectively prevent fraud and ensure the security and legitimacy of your account.
- Some apps, films, or subscription services are restricted by copyright and distribution agreements. Linking a local payment method will help the system accurately determine whether you are authorised to continue using or accessing these services in the new country/region, ensuring the continuity of services and content.
Solution
1. Before switching the country/region of your account, prepare a payment method for the new country/region and follow the onscreen instructions to link a bank card.
2. If you do not want to enter a payment method, you can also register a new HUAWEI ID in the target country/region.