When using a 2G/3G SIM card, the 4G icon appears intermittently and then my device disconnects from the mobile data network

Applicable products: Tablet,Smartphone
Applicable system: Unrelated to OS version
Applicable products:
Applicable system:
These are your search results, please select one
No results found, please select again
zoom in pic
When using a 2G/3G SIM card, the 4G icon appears intermittently and then my device disconnects from the mobile data network

Problem:

After a 2G/3G SIM card is installed on the phone, the 4G signal icon is displayed repeatedly and the phone disconnects from the 4G network.

Cause:

If 4G network is available in your local area but 4G services are not enabled on your phone, the phone will attempt to register with the 4G network because it is given higher priority. When the network detects that your phone hasn't enabled 4G services, the network access is rejected, resulting in your phone repeatedly displaying the 4G signal icon and disconnecting from the network.

Solution:

To solve this, swipe down from the status bar to open the notification panel and tap and hold the Mobile data icon to enter the settings screen. Turn off the Enable 4G switch or set the Preferred network mode to 4G/3G/2G auto.Also we recommend to use a SIM card that supports 4G services in order to enjoy faster Internet speed when using the mobile data.

If Enable 4G or Network mode is not displayed, it indicates that 4G is enabled on your phone by default.

More knowledge:

The phone has an unstable signal

Helpful or not?
Thanks for your feedback.