AR Measure on my HUAWEI phone is unable to measure distance or fails to accurately measure distance
Applicable products: HUAWEI P50 Pocket,HUAWEI Mate 40 Pro,HUAWEI Mate 30 Pro,HUAWEI P30 Pro,HUAWEI Mate X,HUAWEI Mate Xs,HUAWEI P40 Pro,HUAWEI Mate 30 Pro 5G,HUAWEI P40 Pro+,HUAWEI P50 Pocket Premium Edition
Applicable system: EMUI 10.0.1, Magic UI 3.1.1, EMUI 9.1, HarmonyOS 3.0, HarmonyOS 2.0, Magic UI 2.0.1, EMUI 10.0, HarmonyOS 2.0.1, EMUI 10.1, EMUI 11.0
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AR Measure on my HUAWEI phone is unable to measure distance or fails to accurately measure distance

Problem:

The user uses AR Measure on their HUAWEI phone to measure distance, but a message keeps appearing, asking the user to move the phone slowly to find a plane, and the measurement function cannot be used.

Cause:

  • The device orientation permission is disabled for AR measurement.
  • The message displays because the measurement result needs to be projected to a plane. Measurement precision may vary depending on the measurement environment and object size.

Solution:

To facilitate the measurement, perform the following:

  • Enable the device orientation permission for AR measurement by going to Settings > Privacy > Permissions > Device orientation and enabling AR Measure.
  • If you are measuring horizontally (such as the length of a floor), look for a horizontal plane.
  • If you are measuring vertically (such as the height of a picture on the wall), look for a vertical plane.
  • Maintain a distance of 0.3–1.5 m between your phone and the target object.
  • Move your phone slowly while measuring.
  • Avoid measuring objects that are transparent, reflective, all white, or moving. Do not measure in environments that are too dark or too bright.
  • When your phone heats up or the phone system freezes, the measurement result may be inaccurate.

If you cannot find AR Measure on a HUAWEI Mate 60 series or HUAWEI Mate X5 series phone, update your phone system to the latest version and try again.

If the issue persists or you encounter any difficulties while doing this, please go to an authorised Huawei Customer Service Centre for assistance.

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