The Bluetooth mouse disconnects from the computer after a connection is established between the two devices
The Bluetooth mouse disconnects from the computer after a connection is established between the two devices |
Problem
Problem 1: After the Bluetooth mouse has been connected to the computer and the computer wakes up from hibernation or sleep, or the Bluetooth mouse is restarted, the mouse disconnects from the computer.
Problem 2: The Bluetooth mouse has been connected to the computer but it constantly disconnects then reconnects.
Cause 1
This may occur due to the power-saving mechanism of the Windows 10 system. Bluetooth will automatically disconnect to save power.
Solution 1
1. Right-click the Windows icon, go to Device Manager > Bluetooth, double-click the corresponding driver such as Intel(R) Wireless Bluetooth(R), touch Power Management, then deselect Allow the computer to turn off this device to save power. This tab is not available on Windows 10 20H1/20H2.
Note: The Bluetooth driver may vary with products.
2. Unplug the charger from your computer, disable the driver, then shut down the computer. Power on the computer again, and enable the driver after entering the system. Please note that you need to shut down your computer instead of restarting it. Check whether this issue can be resolved.
To disable the driver: Since your computer can't connect to the mouse, use the touchpad to right-click the Windows icon and open Device Manager. Go to Bluetooth > Intel(R) Wireless Bluetooth(R) and click the Disable icon.
To enable the driver: Since your computer can't connect to the mouse, use the touchpad to right-click the Windows icon and open Device Manager. Go to Bluetooth > Intel(R) Wireless Bluetooth(R) and click the Enable icon.
Cause 2
The internal program of the mouse may be faulty. As a result, the mouse runs abnormally.
Solution 2
Reset the Bluetooth mouse and try pairing again. To do this, perform the following:
- If you are using an AF30 mouse:
When your mouse is powered off, press both the right and left buttons at the same time, switch the button on the rear case to the Bluetooth icon, then wait for 3 seconds until the indicator on the back of the mouse flashes blue, which indicates that the mouse has been restored to its factory settings.
The following figure shows how you can do this.
- If you are using an HONOR AD20 or a HUAWEI CD20:
When your mouse is powered off, press the right and left buttons and the scroll wheel at the same time, switch the button on the rear case to the power-on icon and wait for 3 seconds, then release the right and left buttons and the scroll wheel. If the red indicator is on, it indicates that the mouse has been restored to its factory settings.
The following figure shows how you can do this.
Cause 3
The Bluetooth driver is faulty.
Solution 3
- Update the Bluetooth driver on your computer using PC Manager.
- Install the latest Windows patches.
Click Check for updates, and the system will automatically download the latest Windows patches. After the download is complete, restart the laptop and the installation will be successful.
If the issue persists, back up important data, use F10 to restore your device to its factory settings. If the issue remains unresolved, take your device and proof of purchase to a nearby authorised Huawei Customer Service Centre for assistance.