Unable to pair my HUAWEI M-Pencil Series stylus with a HUAWEI tablet

Applicable products: Tablet
Applicable products:
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Unable to pair my HUAWEI M-Pencil Series stylus with a HUAWEI tablet

The following applies only to HUAWEI tablets. If you are using a 2-in-1 laptop, please refer to HUAWEI 2-in-1 laptops do not work when connected to a stylus.

Problem

After the user attaches their stylus to a tablet or the stylus charger, they cannot find the stylus in Settings > Bluetooth > PAIRED DEVICES or Settings > More connections > NearLink > PAIRED DEVICES. Specifically:

  • No pairing prompt displays.
  • The pairing prompt keeps loading then shows that the connection fails.

Cause

  • The stylus does not match the tablet model.
  • The stylus is not attached to the correct position.
  • The battery level of the stylus is too low or the stylus has powered off.
  • The stylus is connected to more than one tablet at the same time.
  • The stylus is attached with a non-HUAWEI magnetic case.

Solution

  1. Click here to check whether your stylus is compatible with your tablet.
  2. Pair and connect your stylus again by referring to Pairing my stylus with a tablet.

    Attach the stylus closely to the tablet (usually on the side with the volume button) or the stylus charger. If you feel the stylus is loosely attached, move it leftwards or rightwards slightly until it is firmly attached.

  3. Remove any non-HUAWEI magnetic case from the stylus as they may interfere with the stylus. Use a HUAWEI protective case instead.
  4. Charge the stylus for 5 to 10 minutes and try again.
  5. Go to Settings > Bluetooth > PAIRED DEVICES or Settings > More connections > NearLink > PAIRED DEVICES on your tablet. Touch the gear icon next to the stylus name, touch Unpair, and attach it to your tablet again for pairing.
  6. Restart your tablet then your stylus by referring to How to restart HUAWEI M-Pencil (2nd/3rd generation), and try again.
  7. Restart your tablet. Go to Settings > Apps & services > Apps, touch in the upper right corner, and go to Show system processes > M-pencil Floating Menu > Storage > CLEAR DATA to clear the stylus data. Then attach the stylus to your tablet again for pairing.
  8. Restore your tablet's network settings by going to Settings > System & updates > Reset > Reset network settings. Then attach the stylus to your tablet again for pairing.

    Restoring network settings will clear your previous Bluetooth pairing records and Wi-Fi connection records.

  9. Update your tablet OS to the latest version and try connecting the stylus again. To check for updates, go to Settings > System & updates > Software update, and touch CHECK FOR UPDATES.

If the issue persists

If the issue persists, back up your data and take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.

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