¿Por qué no se pueden realizar pagos dentro de aplicaciones ni renovarse los servicios de suscripción automáticamente en el caso de aplicaciones descargadas desde HUAWEIAppGallery?
Productos aplicables: Tablet,Smartphone
Productos aplicables:
zoom in pic
¿Por qué no se pueden realizar pagos dentro de aplicaciones ni renovarse los servicios de suscripción automáticamente en el caso de aplicaciones descargadas desde HUAWEIAppGallery?

Problema:

  • Falla de pago: Un pago dentro de la aplicación falló, pero no hay un mensaje de error que indique el por qué.
  • Servicio de suscripción: Las suscripciones activas no se pueden renovar automáticamente.

Motivo:

Si una aplicación o un juego no se ofrece en la región de servicio configurada para tu cliente de HUAWEIAppGallery, no podrás realizar pagos allí, pero los servicios de aplicaciones/juegos adquiridos previamente seguirán siendo válidos. En cuanto a los servicios de suscripción, expirarán una vez que finalice el período de suscripción actual y no se podrán renovar automáticamente.

Solución:

1. Actualiza HMS Core (Servicios Móviles de Huawei) a la versión más reciente. Si la aplicación en cuestión no se ofrece en la región de servicio configurada para tu cliente de HUAWEIAppGallery, el sistema mostrará un mensaje indicando la causa de la falla cuando tu pago falle.

2. Accede a AppGallery > Yo > Ajustes > País/Región, cambia el área de servicio al país o a la región donde descargaste la aplicación en cuestión. Luego, podrás hacer pagos y habilitar las renovaciones automáticas para la aplicación.

¿Esto fue útil o no?
Gracias por su comentario.