The charging port of my HUAWEI phone/tablet is liquid-damaged or has foreign objects, or the USB port is wet, causing charging failure, intermittent charging, or fast charging failure
Applicable products:
Tablet,Smartphone
Applicable system:
Unrelated to OS version
Applicable products:
Applicable system:
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The charging port of my HUAWEI phone/tablet is liquid-damaged or has foreign objects, or the USB port is wet, causing charging failure, intermittent charging, or fast charging failure |
Problem:
The phone/tablet is connected to a charger, headset, computer USB port, or mobile power supply, and does not charge, charges intermittently, or does not support fast charging due to liquid damage, foreign objects, or USB port moisture. The phone/tablet displays a message indicating that the USB port is moist or a non-standard device is inserted.
Cause:
- Your phone/tablet's USB port may be damaged if water or other liquids infiltrate it. If this occurs, your phone/tablet will temporarily disable headset functions, super fast charging, and USB connectivity, for safety reasons.
- Some non-HUAWEI data cables or adapters may be incompatible with your phone/tablet, and the message indicating that the USB port is moist or a non-standard device is inserted may be displayed.
Solution:
- Check whether there are any foreign objects in the charging port. If so, clean the charging port when the device is powered off using a dry tissue or cloth (avoid leaving bits of tissue in the port), and then charge the device.
- If there is liquid in the charging port, move your phone/tablet to a dry and well-ventilated location, and clean the charging port with a paper tissue, or use a fan to dry the water. Make sure that your phone/tablet is powered off.
- Check whether the charging port is slightly eroded. If so, use a toothbrush or a brush to gently clean the port with a small amount of alcohol, and then repeatedly insert and remove the data cable. Then try charging again.
- Use a HUAWEI USB data cable or adapter instead, and try again.
If the issue remains unresolved or the charging port is damaged, back up your data in advance and take your device and proof of purchase to a Huawei Customer Service Center for assistance.
Thanks for your feedback.