My HUAWEI computer's hard drives are password protected
| My HUAWEI computer's hard drives are password protected |
Problem
Problem 1: When the user resets their computer, the message "The disk is locked, please enter the password" or "Enter the recovery key for this drive" is displayed.
Problem 2: Drives such as drive C and drive D are encrypted and cannot be accessed. The user needs to enter the key to unlock the computer.
Cause
After a Microsoft account is logged in to the Windows system, the BitLocker feature is enabled by default. This feature encrypts the system startup drive, which can prevent the system from updating boot files during scenarios such as startup, system reset, or disk access, resulting in the system failing to start and displaying an error message.
- BitLocker provides two functions:
- Device encryption is designed to simplify use and is usually automatically enabled.
- BitLocker drive encryption is designed for advanced solutions and can be used to manually encrypt drives.
- Windows Home does not support BitLocker drive encryption. The higher version of the OS is required.
Solution
|
No. |
Problem |
Solution |
|---|---|---|
|
1 |
When the user resets their computer, the message "The disk is locked, please enter the password" or "Enter the recovery key for this drive" is displayed. |
If the system can be accessed, click Solution. |
|
If the system cannot be accessed, click Solution. |
||
|
2 |
Drives such as drive C and drive D are encrypted and cannot be accessed. The user needs to enter the key to unlock the computer. |
Click Solution. |
For problem 1:
- If the system can be accessed, disable disk encryption. The procedure is as follows:
- In the search box at the bottom of the computer, search for and open Device encryption.
- In the displayed dialog box, click Off.
- Check that the device encryption status is Off.
To disable BitLocker in Windows 11, do as follows:
Go to Start > Settings > Privacy & security > Device security > Manage BitLocker drive encryption and disable BitLocker.
- If your computer cannot enter the system, find the recovery key on the Microsoft official website using another computer or mobile phone, and disable disk encryption after entering the system. The specific steps are as follows:
- Record the website, key ID, and drive label displayed on the screen where you are prompted to enter the recovery key.
- Use another device that can access the Internet to visit https://account.microsoft.com/devices/recoverykey and log in to the website with the information you recorded.
- Enter the correct Microsoft account and password used to log in to the device where the recovery key is required.
If you forget the Microsoft account or password used to log in to the device, you may not be able to query the recovery key. In this case, you are advised to use your frequently used mobile number or email address to confirm the Microsoft account or retrieve the password.
- After logging in to the Microsoft account and verifying the password, find the key information in the recovery key list based on the recorded key ID and drive label.
- Enter the queried recovery key on the Reset this PC or F10 factory settings verification screen, and then you can continue with the next step.
You do not need to enter the hyphen (-) in the middle of the key.
- After the computer is reset or restored to factory settings by pressing F10, complete the startup configuration and enter the system. Search for "Device encryption" in the search box on the taskbar and check whether this feature is disabled. If Device encryption has been disabled, you can use the computer as usual. If Device encryption has not been disabled, disable it and then use the computer.
For problem 2:
- Manually search for the recovery key on the Microsoft official website, enter the recovery key to unlock the drive, and disable Device encryption. The procedure is as follows:
- Record the website, key ID, and drive label displayed on the screen where you are prompted to enter the recovery key.
- Use another device that can access the Internet to visit https://account.microsoft.com/devices/recoverykey and log in to the website with the information you recorded.
- Enter the correct Microsoft account and password used to log in to the device where the recovery key is required.
If you forget the Microsoft account or password used to log in to the device, you may not be able to query the recovery key. In this case, you are advised to use your frequently used mobile number or email address to confirm the Microsoft account or retrieve the password.
- After logging in to the Microsoft account and verifying the password, find the key information in the recovery key list based on the recorded key ID and drive label.
- Enter the queried recovery key on the disk unlock verification screen, and then you can continue with the unlock verification.
- After the disk is unlocked, search for "Device encryption" again in the search box on the taskbar, and check whether this feature has been disabled. If Device encryption has been disabled, you can use the computer as usual. If Device encryption has not been disabled, disable it and then use the computer.
The number of keys generated is the same as the number of encrypted partitions. Click Continue to decrypt the key for the second partition.
If the issue persists
Huawei has reported this issue to Microsoft. Please stay tuned for future updates. Update availability is dependent on Microsoft. If you have any questions, contact Microsoft customer service for further assistance.