My HUAWEI computer cannot access the Internet after connecting to a Wi-Fi network

Applicable products: PC,Desktop
Applicable system: Windows 10, Windows 11
Applicable products:
Applicable system:
Results of query below
Unable to find results for the query, please try different key words
zoom in pic
My HUAWEI computer cannot access the Internet after connecting to a Wi-Fi network

Problem

After the computer is connected to a hotspot, the Wi-Fi icon is displayed as connected, but the computer cannot obtain a network connection.

Cause

  • The computer system file is modified.
  • Some network system parameters may have been tampered with due to software conflicts or viruses.
  • The router or network environment is abnormal.

Solution

If the computer's network icon indicates that an error occurs when you go to Network & internet > Proxy and the computer cannot connect to a network, refer to My HUAWEI computer cannot connect to a Wi-Fi network to resolve the issue.

  1. To check the network settings of the computer, perform the following steps:
    1. Press and hold Win+I, go to Settings > Network & internet > Proxy, and disable Manual proxy setup.

      Click to go to Network & internet > Proxy

    2. In the search box on the taskbar, search for and open Internet Options. Click Advanced, select Use TLS 1.0, Use TLS 1.1, and Use TLS 1.2, deselect Use SSL 3.0 and Use TLS 1.3, and click Restore advanced settings in the lower right corner of the window. Then go to Apply > OK to save the settings and restart your computer.

  2. Connect the device to another network (such as your phone's mobile data hotspot). Try connecting to multiple networks when necessary. If the computer can access the Internet as normal when it is connected to other networks, the computer is normal and the problem may be caused by network restrictions of the router. In this case, power off the router and optical modem, connect to the power supply again 5 to 10 minutes later, and restart the computer. If the issue persists, it is recommended that you restore the router to its factory settings and reconfigure it.

    The methods of restoring factory settings and reconfiguring the router vary depending on the router brand. If you have any question when configuring your router, contact the router vendor for assistance.

  3. To modify the network configuration of the computer, perform the following steps:
    1. Remember the network password and reset the network settings of the computer.
    2. Refresh the DNS cache and perform the following steps to set the IP address and DNS server address.
      1. Enter Control Panel in the search box on the taskbar and open Control Panel. Change the view mode of the control panel to Large icons or Small icons. Then click Network and Sharing Center.

      2. Click Change adapter settings, right-click the network adapter you want to configure, and click Properties from the drop-down list.

      3. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.

      4. Select Obtain an IP address automatically, change the DNS server address setting, and click OK. Restart the computer and try again.
        • If Obtain DNS server address automatically is enabled, select Use the following DNS server addresses, and set Preferred DNS server and Alternate DNS server to 114.114.114.114 and 8.8.8.8 respectively. For details, see Setting the DNS server addresses.
        • If Use the following DNS server address is enabled, select Obtain DNS server address automatically.

  4. If the issue persists, back up your data, record your Office account that has been activated, use F10 to restore your device to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.
Helpful or not?
Thanks for your feedback.