The touchscreen of my HUAWEI computer responds slowly, freezes, is insensitive, or does not work

Applicable products: PC,Desktop
Applicable products:
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The touchscreen of my HUAWEI computer responds slowly, freezes, is insensitive, or does not work

This applies only to computers that support touchscreens.

Problem

The touchscreen of the HUAWEI computer responds slowly, freezes, is insensitive, or does not work.

Cause

  • The system resource usage is too high.
  • This is a compatibility issue with third-party apps.
  • The touchscreen driver is abnormal or the touchscreen is disabled.

Solution

If the touchscreen of your computer responds slowly, freezes, is insensitive, or does not work, perform the following steps to troubleshoot:

  1. Press the Power button for 1 to 2 seconds to turn off the computer screen. Wait for 2 to 3 minutes and try again.

    Here, press the Power button to turn off the computer screen, not power off the computer.

  2. Press and hold the Win+X and choose Device Manager from the shortcut menu. In the displayed Device Manager window, choose Human Interface Devices, and check whether the driver status of HID-compliant touch screen is normal.
    1. If the ↓ arrow displays on the driver icon, right-click HID-compliant touch screen and choose Enable device from the shortcut menu.

    2. If the driver icon displays properly, right-click HID-compliant touch screen and choose Uninstall device from the shortcut menu. In the displayed dialog box, click Uninstall. After the driver is uninstalled, restart the computer and try again. If you are using a HUAWEI MateBook E 2019/Go, skip this step.

    3. If the driver icon does not display, restart the computer, open the Device Manager again, and click Scan for hardware changes to reinstall the touchscreen driver and try again.

  3. Go to Huawei PC Manager > Optimization > Manage drivers, click Check for updates/UPDATE, and update the computer drivers to the latest version.

  4. Check whether there are many apps running in the background or if memory-intensive apps such as games are running. Close these apps and check whether this resolves the issue. The detailed operations are as follows:
    1. Right-click in any blank area or on the Start menu icon () on the taskbar, select Task Manager, select the apps that occupy a lot of memory or disk space in Processes, and click End task.

    2. Click CPU and Memory to check whether there are some unnecessary tasks that are taking up much CPU or memory. If so, right-click the unnecessary task, then select End task, or click the task and then click End task in the lower right corner.

  5. Check whether this issue occurs after certain software is installed or the system is updated. If so, uninstall the corresponding software and the latest Windows system patch. To do so, perform the following:

    Before uninstalling the system patch, back up important data on the computer in case of data loss.

    1. Go to Control Panel > Uninstall a program. In the list of installed software, check whether specific software has been installed before the touchscreen failure occurs. If the corresponding software exists, right-click the software and choose Uninstall from the shortcut menu. (If such software does not exist, skip this step.)

    2. Click View installed updates on the left of the installed program list. In the installed update list, check whether a specific system update has been installed before the touchscreen failure occurs. If there is an update record, right-click the update and choose Uninstall from the shortcut menu. (Skip this step if there is no such update record.)

    3. If an update is uninstalled, enter Services in the search box on the taskbar and open it. In the displayed Services dialog box, search for and double-click Windows Update, set Startup Type to Disabled, and click OK. Double-click Windows Update again, click on the Restore tab, set First failure to Take no action, click Apply then OK, and restart the computer immediately. (Skip this step if no update patch can be uninstalled or if the update patch cannot be uninstalled.)

If the issue persists

If the issue persists, back up your data in advance, record your Office account, and use F10 to restore your computer to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.

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