PC Manager on my HUAWEI computer repeatedly displays a message indicating that the graphics card driver needs to be updated

Applicable products: PC
Applicable products:
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PC Manager on my HUAWEI computer repeatedly displays a message indicating that the graphics card driver needs to be updated

This is not applicable to the HUAWEI MateBook 16.

Problem

After the Intel integrated graphics card driver is updated using PC Manager and the computer is restarted, the system still displays a message indicating that the driver needs to be updated.

Cause

The old version of the Intel integrated graphics card driver was not uninstalled successfully. As a result, the new version of the driver cannot be installed successfully. In this case, PC Manager still detects the old version of the driver, so it prompts you to update the driver again.

Solution

  1. Press Win+X and then press the M key on the keyboard, or press Win+X and select Device Manager from the list that is displayed in the lower left corner to open it.
  2. Uninstall the old version of the graphics card driver.
    1. In Device Manager, expand Display adapters, right-click Intel(R) UHD Graphics 620, and select Uninstall device from the shortcut menu.

    2. In the displayed Uninstall Device dialog box, select the check box Delete the driver software for this device. and click Uninstall.

    3. After the uninstallation is complete, click the Refresh button on the toolbar of Device Manager and select Scan for hardware changes (as shown in the following figure). Ensure that the Microsoft inbox driver Microsoft Basic Display Adapter is displayed under Display adapters.

  3. Uninstall the Intel display audio driver. (The operations are the same as those in step 2.)
    1. In Device Manager, expand Sound, video and game controllers, right-click Intel(R) Display Audio, and select Uninstall device from the shortcut menu.

    2. In the displayed Uninstall Device dialog box, select the check box Delete the driver software for this device. and click Uninstall.

    3. After the uninstallation is complete, click the Refresh button on the toolbar of Device Manager and select Scan for hardware changes (as shown in the following figure). Make sure that Intel High Definition Audio displays with a yellow exclamation mark.

      If you have installed the driver multiple times, Intel(R) Display Audio may load again after Device Manager is refreshed. In this case, you can uninstall the driver several times until Intel High Definition Audio displays with a yellow exclamation mark. You will then be able to update the driver.

  4. After performing steps 2 and 3, restart the computer immediately and update the graphics card driver using Huawei PC Manager. Open PC Manager, go to Optimization > Drivers (for some versions of PC Manager, directly click Drivers in the left pane), and follow the onscreen instructions to download and update drivers.

    The driver packages for certain models are available on the official website. You can download the driver package and manually install it as required.

If the issue persists

If the issue persists, back up your data in advance, record your Office account, and use F10 to restore your computer to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. We will do our best to address your needs.

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