Pourquoi les paiements dans les applications ne peuvent-ils pas être effectués/les services d'abonnement ne peuvent-ils pas être automatiquement renouvelés pour les applications téléchargées depuis HUAWEIAppGallery ? |
Problème :
- Échec du paiement : Un paiement dans une application a échoué, mais il n'y a pas de message d'erreur indiquant pourquoi il a échoué.
- Service d'abonnement : Les abonnements actifs ne peuvent pas être renouvelés automatiquement.
Cause :
Si une application/un jeu n'est pas distribué dans la région de service que vous avez définie pour votre client HUAWEIAppGallery, vous ne pourrez pas y effectuer de paiements, mais les services d'application/de jeu précédemment achetés seront toujours valides. Quant aux services d'abonnement, ils expireront une fois la période d'abonnement en cours terminée et ne pourront pas être renouvelés automatiquement.
Solution :
1. Mettez à jour HMS Core (Huawei Mobile Services) à la dernière version. Si l'application en question n'est pas distribuée dans la région de service que vous avez définie pour votre client HUAWEIAppGallery, le système affichera un message indiquant la cause de l'échec lorsque votre paiement échoue.
2. Accédez à
et changez la zone de service sur le pays/la région où vous avez téléchargé l'application en question. Après cela, vous pourrez effectuer des paiements et activer les renouvellements automatiques pour l'application.