Unable to play music found in Petal Search

Applicable products: HUAWEI Vision S
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Unable to play music found in Petal Search

Problem:

When the user clicks music found in Petal Search on the Vision, a message is displayed indicating that This service isn't supported in your current region.

Cause:

Currently, Petal Search is only available on the Vision in the following five countries: Malaysia, the Philippines, Saudi Arabia, Spain, and Russia. Music found in Petal Search cannot be played if the service country or region of your HUAWEI ID is not on this list.

Solution:

Change the service country or region of your HUAWEI ID to any of the above countries (Malaysia, the Philippines, Saudi Arabia, Spain, and Russia) on your Huawei phone or tablet that is connected to your Vision by going to Settings > System & updates > Language and region > Language and region (this applies to devices running EMUI 10.0.1. The operations may vary slightly depending on the EMUI version). Then try searching for music again in Petal Search.

If the issue persists, log in to your HUAWEI ID again or restart your Vision.

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