Microsoft Edge frequently crashes or breaks down
Applicable products: PC
Applicable system: Windows 10, Windows 11
Applicable products:
Applicable system:
Results of query below
Unable to find results for the query, please try different key words
zoom in pic
Microsoft Edge frequently crashes or breaks down

Problem

Microsoft Edge frequently crashes and does not function properly.

Cause

  • There is a low probability that this issue occurs during app reconfiguration when the user creates a Local User on the computer.
  • A Microsoft Edge exception occurs.

Solution

  1. Reset Microsoft Edge by performing the following steps:
    For an early version of Microsoft Edge:
    1. Click the Windows icon and then the Settings icon, and select Apps.

    2. Click Apps & features, find Microsoft Edge on the right and click it, then select Advanced options.

    3. Go to Reset > Reset. A tick icon will then be displayed next to the Reset icon.

    For a new version of Microsoft Edge:
    1. Open Microsoft Edge, click ... in the upper right corner, and go to Settings > Reset settings.

    2. Click Reset. After the reset is complete, close Microsoft Edge and re-open it.

  2. Delete the cache files related to Microsoft Edge by performing the following steps:
    1. Open This PC or File Explorer on the desktop, go to View > Show/hide, and select Hidden items.

    2. Go to the C:\Users\account name\AppData\Local\Microsoft directory and delete the Edge folder in the directory.

    3. Restart the computer.
  3. Open Control Panel, click Uninstall, find the software related to 2345, and select it to uninstall it.

  4. Download the latest version of Microsoft Edge from the official Microsoft Edge website. If this does not work, install the Dev version and try again.
Helpful or not?
Thanks for your feedback.