Microsoft Edge frequently crashes or breaks down
Applicable products:
PC
Applicable system:
Windows 10, Windows 11
Applicable products:
Applicable system:
Results of query below
Unable to find results for the query, please try different key words
Microsoft Edge frequently crashes or breaks down |
Problem
Microsoft Edge frequently crashes and does not function properly.
Cause
- There is a low probability that this issue occurs during app reconfiguration when the user creates a Local User on the computer.
- A Microsoft Edge exception occurs.
Solution
- Reset Microsoft Edge by performing the following steps:
For an early version of Microsoft Edge:
- Click the Windows icon and then the Settings icon, and select Apps.
- Click Apps & features, find Microsoft Edge on the right and click it, then select Advanced options.
- Go to Reset icon. . A tick icon will then be displayed next to the
For a new version of Microsoft Edge:- Open Microsoft Edge, click ... in the upper right corner, and go to .
- Click Reset. After the reset is complete, close Microsoft Edge and re-open it.
- Delete the cache files related to Microsoft Edge by performing the following steps:
- Open This PC or File Explorer on the desktop, go to View > Show/hide, and select Hidden items.
- Go to the C:\Users\account name\AppData\Local\Microsoft directory and delete the Edge folder in the directory.
- Restart the computer.
- Open Control Panel, click Uninstall, find the software related to 2345, and select it to uninstall it.
- Download the latest version of Microsoft Edge from the official Microsoft Edge website. If this does not work, install the Dev version and try again.
Thanks for your feedback.