Error code C5 is displayed when my printer is working
Applicable products:
HUAWEI PixLab B5,HUAWEI PixLab X1
Applicable system:
Unrelated to OS version
Applicable products:
Applicable system:
Results of query below
Unable to find results for the query, please try different key words
| Error code C5 is displayed when my printer is working |
Problem
Error code C5 is displayed when the printer is working.
Cause
The printer has detected that there is no drum cartridge.
Solution
- Check whether the drum cartridge is inserted properly in the printer. You can take out the drum cartridge and reinsert it.
- Restart the printer.
- If the issue persists, escalate it to R&D personnel.
Thanks for your feedback.