Error code C5 is displayed when my printer is working

Applicable products: HUAWEI PixLab B5,HUAWEI PixLab X1
Applicable system: Unrelated to OS version
Applicable products:
Applicable system:
Results of query below
Unable to find results for the query, please try different key words
zoom in pic
Error code C5 is displayed when my printer is working

Problem

Error code C5 is displayed when the printer is working.

Cause

The printer has detected that there is no drum cartridge.

Solution

  1. Check whether the drum cartridge is inserted properly in the printer. You can take out the drum cartridge and reinsert it.
  2. Restart the printer.
  3. If the issue persists, escalate it to R&D personnel.
Helpful or not?
Thanks for your feedback.