Prompt "No contacts with numbers"/"Syncing..." displays when I add favorite contacts on my third-party Android phone to the connected HUAWEI watch/band
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| Prompt "No contacts with numbers"/"Syncing..." displays when I add favorite contacts on my third-party Android phone to the connected HUAWEI watch/band |
Problem
- The user cannot add a favorite contact on their third-party Android phone to the connected HUAWEI watch/band, and the prompt "No contacts with numbers" displays when the user goes to Huawei Health > Devices, taps the connected device, and selects Favorite contacts.
- The user cannot sync contacts on their third-party Android phone to the connected HUAWEI WATCH 3/4/5 Series, Ultimate 2, GT 6 Series, or GT Runner 2, and the prompt "Syncing..." displays when the user syncs contacts in the watch Contacts app.
Cause
Third-party Android phones provide the function of protecting contact information for apps. Once enabled, the system will provide empty contacts instead of real contacts to avoid personal data leakage. When this function is enabled for the Huawei Health app, the app can only obtain empty contacts even though it has the permission to read contacts. As a result, the syncing fails, and the prompt "No contacts with numbers" or "Syncing..." displays.
Solution
It is recommended that you disable the contact information protection function for the Huawei Health app on your phone. The detailed operations vary depending on your phone model. The following is for reference only. If you have any difficulty in disabling this function, please contact the phone vendor.
For OPPO phones: Go to Settings > Privacy & permissions > Privacy substitute, and then find and toggle off the switch for Huawei Health.
For vivo phones: Go to Settings > Apps & permissions > Permission management > Contacts > Huawei Health, toggle off Provide blank info, and set the Contacts permission to Allow/Allow all the time.
For Xiaomi phones: Go to Settings > App settings > Huawei Health > Permission management > Read contacts, toggle off Blank pass, and set the Read contacts permission to Allow/Allow all the time.
For OnePlus phones: Go to Settings > Privacy & permissions > Privacy substitute, and then find and toggle off the switch for Huawei Health.
If the issue persists, please call the Huawei customer service hotline for further assistance.