プリンタードライバーをインストールできないか、またはプリンタードライバーをインストールしてもプリンターを使用できません |
問題
プリンターをコンピュータに接続しようとしてもうまくいきません。次のような問題が発生する場合があります。プリンターをコンピュータに接続してもプリンターが反応しない/プリンターをコンピュータに接続するとデバイスマネージャーのプリンターアイコンに黄色の感嘆符が表示される/プリンタードライバーをインストールできない/プリンターが正常に動作しない/プリンタードライバーをインストールしてもプリンターが一覧に表示されない。
原因
原因は次のとおりです。プリンタードライバーはCD-ROMでパッケージに添付されているが、コンピュータに CD-ROMドライブがない/インターネットからダウンロードしたドライバーのバージョンがシステムと互換性がない/コントロールパネルでプリンターを追加する設定が間違っている。
解決策
プリンタードライバーをダウンロードしてインストールした後、プリンターを正しく設定してください。
方法1:
- プリンターブランドの公式サイトで対応するプリンターモデルのドライバーをダウンロードします。HP LaserJet Pro P1106を例として使用します。HPの公式サイトにアクセスして、「サポート > 印刷」に移動し、プリンターのモデルを入力して、対応するドライバーをダウンロードします。
- ダウンロードしたプリンタードライバーを解凍します。
- デスクトップのコンピュータアイコンを右クリックし、ショートカットメニューから 管理 を選択します。
- 左側のリストで サービスとアプリケーション を選択し、サービス をダブルクリックします。
- Print Spooler をダブルクリックし、スタートアップの種類を 自動 に設定し、開始 と OK をクリックします。
注意:リソース不足のためPrint Spoolerサービスを開始できないというエラーコード付きのメッセージが表示されたら、タスクバーの検索ボックスに「cmd」と入力し、そのアプリを右クリックして、ショートカットメニューから 管理者として実行 を選択します。表示されたコマンドプロンプトダイアログボックスに「netsh winsock reset」と入力して、Enterキーを押します。続いて、コンピュータを再起動します。これでコンピュータのネットワークがリセットされます。以前に接続したネットワークに接続するには、パスワードの再入力が必要になる場合があります。VPN、共有プリンター、共有LANは、再設定しないと使用できません。
- Printer Extensions and Notifications を選択し、右側の 他の操作 をクリックして、開始 を選択します。(このオプションが表示されない場合は、この手順をスキップします。)
- PrintWorkflowUserSvc を選択し、右側の 他の操作 をクリックして、開始 を選択します。(このオプションが表示されない場合は、この手順をスキップします。)
- Server を選択し、右側の 他の操作 をクリックして、開始 を選択します。
- デスクトップに戻り、解凍したドライバーパッケージの setup プログラムをダブルクリックします。
- 簡易インストール を選択して、次へ をクリックします。
- プリンターモデルを選択し、次へ をクリックします。
- 必要に応じてUSBケーブルでプリンターをコンピュータに接続し、プリンターの電源をオンにします。
- プリンターを設置したら、次へ をクリックし、コンピュータを再起動します。ドライバーをインストールできない場合は、シリアルポートドライバーを更新してください。
再起動が完了した後に、以下のような状況が発生する場合があります。
ドライバーはインストールされましたが、コントロールパネルでプリンターが自動的に認識されません。この場合は、手動でプリンターを追加する必要があります。
以下の手順を実行してください。
- Windowsアイコンをクリックし、設定 > デバイス に移動します。
- プリンターとスキャナー を選択し、プリンターまたはスキャナーを追加します をクリックします。
- プリンターを検出できない場合は、プリンターが一覧にない場合 をクリックします。
- ローカルプリンターまたはネットワークプリンターを手動設定で追加する を選択し、次へ をクリックして、既存のポートを使用 または 新しいポートの作成 を選択し、次へ をクリックします。
- ディスク使用... をクリックします。
- プリンターの公式サイトからドライバーをダウンロードした後に生成された解凍済みのドライバーフォルダを見つけて、対応する.infファイル(通常はプリンターのモデルやシリーズにちなんだ名前が付けられている)を選択し、開く をクリックします。
- OK をクリックします。
- このプリンターを共有しない を選択します。(このプリンターを共有したい場合は、正しいLANアドレスを入力します。)
- テストページの印刷 をクリックし、完了 をクリックします。
ドライバーをインストールできません。この場合、手動でドライバーを追加する必要があります。
デバイスマネージャーを開いて、プリンターを探します。プリンターアイコンに黄色の感嘆符が表示されている場合は、プリンターを右クリックし、ショートカットメニューから ドライバーの更新 を選択します。
注意:
インストールに長い時間がかかったり、インストールを何度も繰り返すと、インストールが失敗したというメッセージが表示されます。この場合は、USBケーブルを取り外し、解凍済みのドライバーフォルダを見つけて、フォルダ内のuninstall.exeを実行します。ドライバーをアンインストールしてから、コンピュータを再起動し、ドライバーを再インストールします。その後、指示に従いUSBケーブルを使用してプリンターをコンピュータに接続します。