Unable to pair my HUAWEI M-Pencil Series stylus with a HUAWEI tablet
Unable to pair my HUAWEI M-Pencil Series stylus with a HUAWEI tablet |
Problem
To view the information about the stylus, perform the following steps:
- HarmonyOS 4.2 or earlier: Go to or .
- No pairing prompt displays.
- The pairing prompt keeps loading then shows that the connection fails.
Cause
- The stylus does not match the tablet model.
- The stylus is not attached to the correct position.
- The battery level of the stylus is too low or the stylus has powered off.
- The stylus is connected to more than one tablet at the same time.
- The stylus is attached with a non-HUAWEI magnetic case.
Solution
- Click here to check whether your stylus is compatible with your tablet.
- Refer to Pair my HUAWEI M-Pencil with a tablet to reconnect your stylus to your tablet.
Attach the stylus closely to the tablet (usually on the side with the volume button) or the stylus charger (attach the middle area of the stylus to the charger). If you feel the stylus is loosely attached, move it leftwards or rightwards slightly until it is firmly attached.
- Remove any non-HUAWEI magnetic case from the stylus as they may interfere with the stylus. Use a HUAWEI protective case instead.
- Charge the stylus for 5 to 10 minutes and try again.
- Open the tablet you are using, tap the icon next to the stylus name, tap UNPAIR, and attach the stylus to the tablet again.
- Restart your tablet then your stylus by referring to How to restart HUAWEI M-Pencil (2nd/3rd generation), and try again.
- Restart your tablet. Go to
in the upper right corner, and go to Show system processes > M-pencil Floating Menu > Storage > CLEAR DATA to clear the stylus app data. Then attach the stylus to your tablet again for pairing.
, tap - Restore your tablet network settings, and attach the stylus to your tablet again for pairing.
To restore your tablet network settings, perform the following steps:
Restoring network settings will clear your previous Bluetooth pairing records and Wi-Fi connection records.
- HarmonyOS 4.2 or earlier: Go to .
- Update your tablet to the latest system version, and then try connecting the stylus again.
If the issue persists
If the issue persists, back up your data and take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.