Warum können für Apps, die über die HUAWEIAppGallery heruntergeladen wurden, keine In-App-Zahlungen getätigt/Abonnement-Dienste automatisch verlängert werden? |
Problem:
- Zahlungsfehler: Eine In-App-Zahlung ist fehlgeschlagen, aber es gibt keine Fehlermeldung, die angibt, warum sie fehlgeschlagen ist.
- Abonnement-Dienst: Aktive Abonnements können nicht automatisch verlängert werden.
Ursache:
Wenn eine App/ein Spiel nicht in der Serviceregion vertrieben wird, die du für deinen HUAWEIAppGallery-Client eingestellt hast, kannst du dort keine Zahlungen tätigen, aber die zuvor gekauften App-/Spieldienste sind weiterhin gültig. Abonnement-Dienste laufen aus, sobald der aktuelle Abonnement-Zeitraum endet und können nicht automatisch verlängert werden.
Lösung:
1. Aktualisiere HMS Core (Huawei Mobile Services) auf die neueste Version. Wenn die betreffende App nicht in der Serviceregion vertrieben wird, die du für deinen HUAWEIAppGallery-Client eingestellt hast, zeigt das System eine Meldung mit der Fehlerursache an, wenn deine Zahlung fehlschlägt.
2. Navigiere zu
und ändere den Servicebereich auf das Land/die Region, in dem/der du die betreffende App heruntergeladen hast. Danach kannst du Zahlungen tätigen und Auto-Verlängerungen für die App aktivieren.