The Bluetooth mouse disconnects from my HUAWEI computer unexpectedly

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The Bluetooth mouse disconnects from my HUAWEI computer unexpectedly

Problem

The Bluetooth mouse disconnects from the computer after a connection is established between the two devices.

Cause

  • Due to the power saving mechanism of Windows, once the Bluetooth mouse has been idle for a certain period of time, the computer automatically disconnects from the Bluetooth module to save power.
  • The internal program of the mouse may be faulty. As a result, the mouse runs abnormally.
  • The Bluetooth driver is unstable or abnormal. As a result, the connection with the Bluetooth mouse is unstable.

Solution

  1. Replace the Bluetooth mouse and try again. If the issue does not occur when another Bluetooth mouse is connected, the previous Bluetooth mouse is faulty or incompatible. In this case, replace the Bluetooth mouse or contact the Bluetooth mouse vendor for assistance. If the issue persists after you replace the Bluetooth mouse, perform the following steps.
  2. Right-click the Windows Start icon, go to Device Manager > Bluetooth, double-click the Bluetooth driver (Intel(R) Wireless Bluetooth(R), Realtek Bluetooth Adapter, or Qualcomm(R) Bluetooth Radio Driver), switch to the Power Management page, and deselect Allow the computer to turn off this device to save power.
  3. Click the Windows Start icon, go to Settings > Devices/Bluetooth & devices, delete the pairing records of the Bluetooth mouse and other Bluetooth peripherals that are not frequently used, and put the mouse in pairing/discoverable mode and try again.
     
    • If you are using a HUAWEI mouse, check the pairing method applicable for your mouse model in Pairing a HUAWEI Bluetooth Mouse with a Windows computer.
    • If you are using a non-HUAWEI mouse, refer to the product manual or contact the customer service personnel of the brand to pair your mouse again.
  4. Save the files in use before you power off your device, and then power it on.
    • Solution 1: Click the Start icon and then the Power icon, select Shut down instead of Restart to power off your device, and then power it on.
    • Solution 2: Press and hold the Power button for 10 seconds to forcibly power off the device, and then power it on.
  5. Disable and then enable the Bluetooth driver. To do so, perform the following steps.
    1. Right-click the Windows Start icon, and go to Device Manager > Bluetooth > Intel(R) Wireless Bluetooth(R)/Realtek Bluetooth Adapter/Qualcomm(R) Bluetooth Radio Driver.
    2. Select Disable device, power off the device (instead of restarting it), and then power it on to enter the system.
    3. Right-click the Windows Start icon again, go to Device Manager > Bluetooth > Intel(R) Wireless Bluetooth(R)/Realtek Bluetooth Adapter/Qualcomm(R) Bluetooth Radio Driver, and select Enable device.

  6. Uninstall and then reinstall the latest Bluetooth driver. To do so, perform the following steps.

    If you are using a HUAWEI MateBook E Go, skip this step.

    1. Right-click the Windows Start icon, and go to Device Manager > Bluetooth > Intel(R) Wireless Bluetooth(R)/Realtek Bluetooth Adapter.
    2. Select Disable device, select Delete the driver software for this device., and click Uninstall. After the uninstallation is complete, restart the device and enter the system.
    3. Go to Huawei PC Manager > Optimization > Drivers, then check for and install driver updates. After the update is complete, follow the onscreen instructions to restart the device again, and pair the Bluetooth mouse again.

  7. Back up important data in advance and update your computer system to the latest version of Windows.
  8. If the issue persists, back up your data, activate your Office account, and use F10 to restore your device to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.
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