アプリの常時実行を許可する方法 スマートフォン側の設定
アプリの常時実行(バックグラウンドで実行)が許可されていなければ、次のような症状が発生する可能性があります。
■症状
・アプリの通知が来たり来なかったりする
(例:LINE、Gメール)
※LINEアプリの通知が全く来ない場合はこちらをご確認ください。
https://consumer.huawei.com/jp/support/content/ja-jp15960378/
■対象
HUAWEI製以外のAndroidスマートフォンを、HUAWEI製のスマートウォッチとペアリングしてご利用の場合
(バックグランドでヘルスケアアプリが常時起動できるよう、一日一回程度ヘルスケアアプリを開いてください。)
■原因
①Bluetoothをオフにしている間はペアリング(スマートフォンとスマートウォッチの通信)が途切れるため、スマートウォッチに通知が届かなくなります。
安定してスマートウォッチで通知を受け取るには、常にスマートフォンのBluetoothをオンにしてご利用ください。
②バックグラウンドで実行中のアプリを停止すると、通知が来たり来なくなったりする状態になります。
ヘルスケアアプリでアプリの通知を受け取るには、ヘルスケアアプリと通知を受け取りたいアプリ双方の常時実行が許可されるよう、次の対処法①②をご確認ください。
■対処法
①お勧めのご利用方法
(1)常にBluetoothを有効にして、ペアリングしておきます。
スマートフォンの「設定」画面でこのように表示されていればBluetoothは有効です。
設定>Bluetooth
HUAWEI healthアプリでこのように表示されていればペアリングされております。
ヘルスケアアプリ>デバイス
(2)ヘルスケアアプリを最新版に更新してください。
※iPhoneをご利用の場合、定期的にAppStoreからヘルスケアアプリを開き、アプリを更新してください。
Androidスマートフォンをご利用の場合、このように表示されていれば、ご利用のヘルスケアアプリは最新版に更新されています。
②バックグラウンドで動いているアプリを閉じないでください。
(1)このようなマルチアプリ画面に、ヘルスケアアプリと通知を受け取りたいアプリ(例:LINE、Gメール)の両方が表示されている状態を保ってください。
(2)アプリを常時実行(バックグラウンドで実行)するよう設定してください。
Androidスマートフォンをご利用の場合は、以下の手順でアプリの常時実行(バックグラウンドで実行)を設定してください。
※iPhoneをご利用の場合、以下の説明は当てはまりません。一日一回程度アプリを開くことで起動状態を保ってご利用ください。
1.ヘルスケアアプリの常時実行
ヘルスケアアプリから現在の設定状況を確認します。
デバイス>端末名(例:HUAWEI Band 8)>バンド接続保護
常時実行に変更するには、設定はこちら>はいの順にタップします。
※ご利用のスマートフォンの設定によって、「設定はこちら」をタップした後の表示が異なる場合がございます。
この場合、『アプリを常時設定に設定変更したい』旨をご利用のスマートフォンメーカーもしくはキャリア窓口までお問い合わせください。
2.通知を受け取りたいアプリの常時実行
(例:LINE、Gメール)
スマートフォンの設定>アプリ>アプリ名(例:LINE、Gメール)>バックグラウンドで実行
※ご利用のスマートフォンの設定によって、通知を受け取りたいアプリの常時実行を設定する方法は異なります。