My computer gets stuck on the HUAWEI logo screen during startup
Applicable products: PC,Desktop
Applicable products:
zoom in pic
My computer gets stuck on the HUAWEI logo screen during startup

Problem

The computer freezes at the HUAWEI logo screen during startup and is unable to load the operating system.

Cause

  • An incompatible USB device may have been connected during startup.
  • An unexpected power-off or system file damage occurs.
  • The solid state disk (SSD) is faulty.

Solution

  1. Remove any USB devices, such as a USB flash drive, external storage drive, mouse, or keyboard, and restart the computer.
  2. Continuously press F10 during startup to enter the Huawei Intelligent Recovery screen. There the computer automatically runs a hardware test. When the hardware test is complete, exit the screen and restart the computer.

  3. If the computer still cannot access the system, use F10 to restore the computer to its factory settings.

    Since the system cannot be accessed, restoring factory settings by pressing F10 will restore the computer desktop and drive C, which may cause data loss. Exercise caution when performing this operation. If you cannot use F10 to restore the computer to its factory settings because there are important documents in the C drive, you are advised to take your device and proof of purchase (such as purchase invoice and purchase order information) to an authorized Huawei Customer Service Center for assistance. Whether the documents can be backed up is subject to the inspection of the Huawei Customer Service Center.

If the issue persists

Take your device and proof of purchase to an authorized Huawei Customer Service Center for further assistance. We will do our best to address your needs.

Helpful or not?
Thanks for your feedback.