Unable to switch the input method on my HUAWEI computer

Applicable products: PC,Desktop
Applicable products:
zoom in pic
Unable to switch the input method on my HUAWEI computer

Problem

  • The icon for the input method, such as Microsoft Pinyin, automatically appears in the language bar, and it's impossible to switch to another input method.
  • There is only a keyboard icon displayed on the language bar, rather than the input method icon, and it's impossible to switch from English to any other language or input method.

Cause

The input method interface of the Windows operating system goes wrong.

Solution

Method 1: Re-configure the input method settings.

  1. Press Win+I to enter the Windows Settings screen, go to Devices > Typing > Advanced keyboard settings, and select Use the desktop language bar when it's available. Then, click Language bar options, and select Docked in the taskbar.

    Click to access the Windows Settings screen.

  2. After the settings are complete, switch the input method and try again.

Method 2: Press Win+R to open the Run window, enter ctfmon.exe, and click OK. This method can be used to restart the CTF loader. You can also manually restart the process in Task Manager.

Method 3: Go to Settings > Devices > Typing > Advanced keyboard settings, select Input language hot keys, and click Change Key Sequence, to restore the default keyboard order.

Method 4: Restore the input method settings.

  • Windows 10: Go to Settings > Time & Language > Language > Preferred languages, select the language you use, click Options, select the Microsoft input method, and go to Options > General > Restore to restore the IME default settings, and then restart your computer.
  • Windows 11: Go to Settings > Time & language > Language & region, click ... on the right of the language you use, select the Microsoft input method, and go to Options > General > Restore to restore the IME default settings, and then restart your computer.

    Click to access the Language settings screen.

If the issue persists

Back up your data and record your Office account in advance, then use F10 to restore your computer to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.

Helpful or not?
Thanks for your feedback.