No sound comes from my HUAWEI computer speakers or external speakers
No sound comes from my HUAWEI computer speakers or external speakers |
Problem
Any of the following issues occur:
- No sound comes from the computer speakers when a video or music is played on the computer.
- Speaker audio suddenly stops during video or music playback.
- Audio can only be heard from one speaker.
Cause
- The computer settings are incorrect. The speakers are muted, or the left/right audio balance is set to 0.
- There is an issue with the audio driver.
Solution
- Forcibly restart the computer.
Press and hold the Power button for more than 10 seconds to forcibly shut down the computer, and press the Power button again to restart the computer. Then, check whether the issue is resolved.
- If so, no further action is required.
- If not, go to step 2.
- Check whether the computer is muted, or whether the left/right audio balance is set to 0.
- On Windows 10 or earlier, right-click the speaker icon in the lower right corner of the desktop and select Sound settings. Maximize the displayed Sound window, and click Sound Control Panel.
On Windows 11, right-click the speaker icon in the lower right corner of the desktop and select Sound settings. Scroll all the way down to find the Advanced section and click More sound settings.
- In the Sound window, go to the Playback tab. Right-click on the default speakers and select Properties. In the displayed Speakers Properties window, make sure that the speakers are enabled with a volume larger than 0, and that neither the left nor right audio balance is 0.
- Then, check whether the issue is resolved.
- If so, no further action is required.
- If not, go to step 3.
- On Windows 10 or earlier, right-click the speaker icon in the lower right corner of the desktop and select Sound settings. Maximize the displayed Sound window, and click Sound Control Panel.
- Check whether the audio driver is faulty.
- Uninstall the existing audio driver following the steps as stated in Installing a driver on a HUAWEI computer.
Uninstalling the current driver is the vital first step in fixing audio driver issues and cannot be skipped. Make sure that the current driver has been uninstalled, or the new driver will not take effect.
- Restart the computer and install the latest driver following the steps as stated in Installing a driver on a HUAWEI computer.
- Then, check whether the issue is resolved.
- If so, no further action is required.
- If not, go to step 4.
Restoring the system to factory settings will delete data in drive C (system drive), including personal files such as desktop files, downloads, and documents. Files in non-system drives (such as drives D and E) will be retained. Make sure to follow the restoration onscreen instructions to back up data in drive C to a non-system drive or an external storage device.
- Uninstall the existing audio driver following the steps as stated in Installing a driver on a HUAWEI computer.
- Restore your computer to its factory settings following the instructions in Use F10 to restore factory settings on a HUAWEI Windows computer. Then, check whether the issue is resolved.
- If so, no further action is required.
- If the issue remains unresolved, back up your data, and take your device and proof of purchase to an authorized Huawei Customer Service Center for hardware checkup. Have the faulty hardware replaced if there is any.