The authentication page loads slowly when I connect my HUAWEI phone/tablet to a public Wi-Fi network

Applicable products: Tablet,Smartphone
Applicable products:
zoom in pic
The authentication page loads slowly when I connect my HUAWEI phone/tablet to a public Wi-Fi network

Problem:

When the user connects their phone/tablet to a public network that requires authentication, such as a campus network, and opens and logs in to the authentication page on the preset browser, UC Browser, or QQ Browser, the web page loads slowly.

Cause:

The cloud boost feature is enabled by default for the browser preset on the phone/tablet (running EMUI 9.0 or an earlier version), UC Browser, and QQ Browser. During a connection, the browser first connects to the transit server on the Internet. However, the Internet network is unavailable before authentication, so the connection to the transit server times out and the page loads slowly or cannot be opened.

Solution:

1. Disable the cloud boost feature on the browser: Open the browser, go to Settings > Acceleration plan, and disable Cloud boost.

2. If the browser does not have the cloud boost feature or the issue persists after the feature is disabled, the public Wi-Fi server may be faulty. Try again later.

3. If the issue remains unresolved, contact the Huawei customer service hotline, or back up your data and then take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance.

To learn more: The authentication page does not display when I connect to a public Wi-Fi network

Helpful or not?
Thanks for your feedback.