My computer freezes or displays a white screen when I right-click on the desktop and select New

Applicable products: PC
Applicable products:
zoom in pic
My computer freezes or displays a white screen when I right-click on the desktop and select New

Problem

When the user right-clicks on the desktop and selects New, the computer freezes for a few seconds and displays the second-level menu, or when the user moves the cursor to New, the mouse cursor is circling or the screen turns white.

Cause

Automatic updates of some patches or frequent default updates of large pre-installed apps in the Microsoft background may cause the computer to freeze occasionally and affect the right-click menu.

Solution

Method 1: Use the Microsoft Update Assistant to update the system to its latest version.

Use the Microsoft Update Assistant to update the system to version 1909 or later. Download the Update Assistant from https://support.microsoft.com/en-us/help/3159635/windows-10-update-assistant. (Note: It can't be used on the MateBook E 2019.)

Method 2: Press F10 to restore factory settings.

Back up important data in advance. Power on the computer and press F10 multiple times or press and hold F10 to restore your computer to its factory settings.

  • Please note that restoring the computer to its factory settings will clear all data in the C drive, including personal files downloaded in Desktop, Downloads, and Documents. Please back up your personal data in the C drive in advance.
  • Your Microsoft Office account will still be valid after restoring the computer to its factory settings. Enter the Microsoft account and password used when you activated the Microsoft Office for the first time and follow the onscreen instructions to log in.
Helpful or not?
Thanks for your feedback.