[HUAWEI] It takes a long time to locate the kids watch

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[HUAWEI] It takes a long time to locate the kids watch

Problem

On the home screen of the HUAWEI FamCare app, the location icon keeps rotating, the message "Locating watch…" is displayed, but the watch's latest location information cannot be obtained.

Cause

To locate the kids watch, the HUAWEI FamCare app will send a locating request to the cloud, which in turn notifies the watch to initiate a location request. After obtaining the location information, the watch will send the information to the cloud. Then, the HUAWEI FamCare app will obtain the current location from the cloud.

Manually locating the watch may take longer if your phone or watch network is slow or unstable.

Solution

  • Check the status bar of your watch and phone to see whether they are connected to a 2G or 3G network. If so, move to an area with better network conditions so that your watch and phone can connect to a 4G network, and touch Locate on the home screen of the HUAWEI FamCare app to manually locate your watch.
  • If both your watch and phone are connected to a 4G network and the video call does not experience obvious frame freezing or delay, contact the Huawei customer service hotline for the issue to be handled by Huawei R&D engineers.
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