Unable to install an app downloaded via Petal Search
Applicable products:
Smartphone
Applicable products:
Unable to install an app downloaded via Petal Search |
Problem:
I cannot install an app downloaded via Petal Search.
Cause 1:
The in-app installations permission to the app has been denied .
Solution:
- Go to
- If you can't find the path mentioned above on your device, please go to to grant the permission.
Cause 2:
The file was damaged during the download.
Solution:
Try to download the app again. If the issue persists, go to
(For versions earlier than 12.0.2) or (For 12.0.2 and later) to submit feedback about the issue, including the following information:- the app name you searched for
- app source
- search language and region
- Petal Search version
- your phone model
- EMUI version (you can check this by going to )
Cause 3:
- Your device is incompatible with the version of the installation package.
- The app developer has not developed a version that supports HMS Core.
Solution:
We are working with app developers to develop more app versions that are compatible with your device.
To check the Petal Search app version, go to:
- For versions earlier than 12.0.2:
- For 12.0.2 and later:
Thanks for your feedback.