An issue occurs when logging in to my HUAWEI ID

Applicable products: Tablet,Smartphone
Applicable products:
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An issue occurs when logging in to my HUAWEI ID

Problem

When logging in to their HUAWEI ID, the user is prompted with "Unable to obtain data. Please try again later.", a message indicating that the server cannot be connected to, or a message indicating that HMS Core is not running.

Cause

  1. The network connection is poor.
  2. The network permission is disabled for HMS Core (Huawei Mobile Services).
  3. If you are not using the latest version of HMS Core, there might be a login failure, as older versions are no longer maintained.

Solution

  1. Switch to a different Wi-Fi or mobile network and try again. Check whether other apps can be used on the same network.

    If you can log in normally using a Wi-Fi network but cannot use a mobile network, the mobile network may be restricted. Perform the following to troubleshoot the issue:

    (1) Open Optimizer (or Tablet Manager) and check whether the Smart Data Saver switch is turned on.

    • EMUI 11.0/10.X/9.X: Go to Data usage > Smart data saver > > Show system processes, touch Smart data saver, find the EXEMPTIONS list, and turn on the switch next to HMS Core.
    • EMUI 8.X: Go to Data usage > Data saver, touch Data saver, find the EXEMPTIONS list, touch System app, and turn on the switch next to HMS Core.

    (2) On the app details screen of HMS Core, enable Data usage, background data, and roaming data. To do so, perform the following:

    • EMUI 11.0/10.X/9.X: Go to Settings > Apps > Apps > HMS Core > Data usage, and enable Data usage, Background data, and Roaming data.
    • EMUI 8.X: Go to Settings > Apps & notifications > Apps > HMS Core > Data usage, and enable Data usage, Background data, and Roaming data.
  2. Open Phone Manager (or Tablet Manager) and allow the network permission for HMS Core by performing the following:
    • EMUI 11.0/10.X: Go to Data usage > Network access > > Show system processes, and select HMS Core.
    • EMUI 9.X and EMUI 8.X: Go to Data usage > Network access > System apps, and select HMS Core.
  3. Open Huawei AppGallery, search for HMS Core, download it or update it to the latest version, then try logging in to the HUAWEI ID again.
  4. If the issue persists, clear the cache of HMS Core and try again.
    • EMUI 11.0/10.X/9.X: Go to Settings > Apps > Apps > HMS Core > Storage, and touch CLEAR CACHE.
    • EMUI 8.X: Go to Settings > Apps & notifications > Apps > HMS Core > Storage, and touch CLEAR CACHE.
  5. If the issue persists, reinstall HMS Core and try again by performing the following:

    (1) Uninstall the updates:

    • EMUI 11.0/10.X/9.X: Go to Settings > Apps > Apps > HMS Core > > Uninstall updates, and touch Uninstall updates.
    • EMUI 8.X: Go to Settings > Apps & notifications > Apps > HMS Core > > Uninstall updates, and touch Uninstall updates.

    (2) Open Huawei AppGallery, search for HMS Core, and update it to the latest version.

    The preceding steps are for Huawei phones only. Operations on other phones will vary.

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