An issue occurs when logging in to my HUAWEI ID |
Problem
When logging in to their HUAWEI ID, the user is prompted with "Unable to obtain data. Please try again later.", or “the server cannot be connected to. Please try again later.
Cause
- The network connection is poor.
- The network permission is disabled for HMS Core (HUAWEI Mobile Services).
- The software version of HMS Core is not latest one.
Solution
Check whether the HMS Core is installed.Go toAppGallery, search for HMS Core, download it or update it to the latest version。
,if it is not found,Open HUAWEI- Check whether the WLAN or mobile network is normal.
Switch to a different Wi-Fi or mobile network and try again. Check whether other apps can be used on the same network.
If you log in normally by using Wi-Fi network and can not log in by mobile network. , the mobile network may be restricted. Troubleshoot the issue as follows:
(1) Open Optimizer (or Tablet Manager) and check whether the Smart Data Saver switch is turned on.
- EMUI 11.0/10.X/9.X: Go to Smart data saver, find the EXEMPTIONS list, and turn on the switch next to HMS Core. , touch
- EMUI 8.X: Go to Data saver, find the EXEMPTIONS list, touch System app, and turn on the switch next to HMS Core. , touch
(2) Check the app details screen of HMS Core, enable Data usage, background data, and roaming data. To do so, perform the following:
- EMUI 11.0/10.X/9.X: Go to Data usage, Background data, and Roaming data. , and enable
- EMUI 8.X: Go to Data usage, Background data, and Roaming data. , and enable
- Open Phone Manager (or Tablet Manager) and allow the network permission for HMS Core by performing the following:
- EMUI 11.0/10.X: Go to , and select HMS Core.
- EMUI 9.X and EMUI 8.X: Go to , and select HMS Core.
- Open HUAWEI AppGallery, search for HMS Core, download it or update it to the latest version, then try logging in to the HUAWEI ID again.
1)If the issue persists, clear the cache of HMS Core and try again.
- EMUI 11.0/10.X/9.X: Go to CLEAR CACHE. , and touch
- EMUI 8.X: Go to CLEAR CACHE. , and touch
2) If the issue persists, reinstall HMS Core and try again by performing the following:
(1) Uninstall the updates:
- EMUI 11.0/10.X/9.X: Go to Uninstall updates. , and touch
- EMUI 8.X: Go to Uninstall updates. , and touch
(2) Open Huawei AppGallery, search for HMS Core, and update it to the latest version.