[HUAWEI] Prompt "No contacts with numbers"/"Syncing..." displays when I add contacts on my third-party Android phone to my HUAWEI watch/band

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[HUAWEI] Prompt "No contacts with numbers"/"Syncing..." displays when I add contacts on my third-party Android phone to my HUAWEI watch/band

Problem

  • The user cannot add a contact on their third-party Android phone to their HUAWEI watch/band, and the prompt "No contacts with numbers" displays when they try to do so through the following operations: Open the Huawei Health app, touch Devices, their device card, and then Favorite contacts.
  • The user has a HUAWEI WATCH 3 Series device and tries to use the Contacts app on the watch to sync contacts from their third-party Android phone. The prompt "Syncing..." displays, and the syncing fails.

Cause

Third-party Android phones provide the function of protecting contact information for apps. Once enabled, the system will provide empty contacts instead of real contacts to avoid personal data leakage. When this function is enabled for the Huawei Health app, the app can only obtain empty contacts even though it has the permission to read contacts. As a result, the syncing fails, and the prompt "No contacts with numbers" or "Syncing..." displays.

Solution

It is recommended that you disable the contact information protection function for the Huawei Health app on your phone. The detailed operations vary depending on your phone model. The following is for reference only. If you have any difficulty in disabling this function, please contact the phone vendor.

If you're using an OPPO phone, go to Settings > Apps > App management > Huawei Health > Permissions > Contacts > Privacy substitute, and turn off the switch.

If you're using a vivo phone, go to Settings > Apps & permissions > Permission management > Permissions > Contacts > Huawei Health, and set Provide blank info to Allow.

If you're using a Xiaomi phone, go to Settings > App settings > Apps > Huawei Health > Permission management > Read contacts, and change the value from Blank pass to Always allow.

If you're using a OnePlus phone, go to Settings > Privacy > Privacy substitute > Huawei Health, and turn off the switch for Protect contacts.

If the issue persists, please call the Huawei customer service hotline for further assistance.

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