接続されているHUAWEIウォッチ/バンドにサードパーティ製Androidスマートフォンのお気に入りの連絡先を追加すると、「番号のある連絡先はありません」/「同期中...」というプロンプトが表示されます
请选择
| 接続されているHUAWEIウォッチ/バンドにサードパーティ製Androidスマートフォンのお気に入りの連絡先を追加すると、「番号のある連絡先はありません」/「同期中...」というプロンプトが表示されます |
問題
- 接続されているHUAWEIウォッチ/バンドにサードパーティ製Androidスマートフォンのお気に入りの連絡先を追加できません。また、Huaweiヘルスケア > デバイス を選択し、接続されているデバイスをタップして よく使う連絡先 を選択すると、「番号のある連絡先はありません」というプロンプトが表示されます。
- 接続されているHUAWEI WATCH 3/4/5シリーズ、Ultimate 2、GT 6シリーズ、またはGT Runner 2にサードパーティ製Androidスマートフォンの連絡先を同期できません。また、ウォッチの連絡先アプリで連絡先を同期すると、「同期中...」というプロンプトが表示されます。
原因
サードパーティ製Androidスマートフォンには、アプリの連絡先情報を保護する機能があります。この機能を有効にすると、個人情報の漏洩を防ぐために、実際の連絡先ではなく空の連絡先が提供されます。この機能がHuaweiヘルスケアアプリに対して有効な場合、アプリに連絡先の読み取り権限があっても取得できるのは空の連絡先のみになります。その結果、同期が失敗し、「番号のある連絡先はありません」または「同期中...」というプロンプトが表示されます。
解決方法
スマートフォンのHuaweiヘルスケアアプリに対する連絡先情報保護機能を無効にすることをお勧めします。詳細な操作は、スマートフォンのモデルによって異なります。以下はあくまでも参考です。この機能を無効にできない場合は、スマートフォンメーカーにお問い合わせください。
OPPOスマートフォンの場合:設定 > プライバシーと権限 > プライバシー代替 を選択し、Huaweiヘルスケアのスイッチを見つけてオフにします。
VIVOスマートフォンの場合:設定 > アプリと権限 > 権限管理 > 連絡先 > Huaweiヘルスケア を選択し、空の情報の提供 をオフにして、連絡先 の権限を 許可 または 常に許可 に設定します。
Xiaomiスマートフォンの場合:設定 > アプリ設定 > Huaweiヘルスケア > 権限管理 > 連絡先の読み取り を選択し、空を渡す をオフにして、連絡先の読み取り の権限を 許可 または 常に許可 に設定します。
OnePlusスマートフォンの場合:設定 > プライバシーと権限 > プライバシー代替 を選択し、Huaweiヘルスケアのスイッチを見つけてオフにします。
問題が解決しない場合は、Huaweiコールセンターにご相談ください。