My HUAWEI computer is unable to identify a third-party docking station
Applicable products: PC
Applicable products:
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My HUAWEI computer is unable to identify a third-party docking station

Problem

The computer cannot identify certain third-party docking stations.

Cause

  • When the computer is connected to certain third-party docking stations, the power consumption suddenly increases. The internal power output protection function of the USB-C port will be enabled (to avoid damaging the computer's mainboard or causing the computer to work abnormally) and the docking station will be disconnected. As a result, it cannot be identified by the computer.
  • The USB port of the computer is not enabled.
  • Certain third-party docking stations may be incompatible with HUAWEI computers.

Solution

  1. If you are using a third-party docking station, connect the charging cable of the power adapter to the USB-C port of the docking station first, and then connect the docking station to the USB-C port of the computer.
  2. Use another docking station and try again. If the issue persists after you replace multiple docking stations or USB devices, perform the following steps:
    1. Uninstall third-party antivirus or manager software and restore the firewall.
    2. Uninstall the USB serial port driver. Go to Device Manager > Universal Serial Bus controllers, right-click USB Root Hub (USB 3.0), click Uninstall device, right-click Universal Serial Bus controllers again, and click Scan for hardware changes. Disconnect the power supply and all external devices. Press and hold the Power button for about 10 seconds to power off and restart the computer.
    3. During the startup or restart of the computer, press and hold or consecutively press F2 to enter the BIOS settings screen. Press F9 to restore the initial BIOS settings, click Yes, and press F10 to save the settings. The USB port is enabled by default in the initial BIOS settings.
  3. It is recommended that you use a standard docking station, such as HUAWEI MateDock 2/3 or a mainstream docking station in the market.

    Before you purchase a docking station, please check with the manufacturer whether it is compatible with your HUAWEI computer.

If the issue persists

If the issue persists, back up your data, activate your Office account, and use F10 to restore your device to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.

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