A network error message is displayed when I open Huawei PC Manager on my HUAWEI computer

Applicable products: PC
Applicable products:
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A network error message is displayed when I open Huawei PC Manager on my HUAWEI computer

Problem

The computer is properly connected to the Internet, but the hardware test and driver management pages of Huawei PC Manager display Network error. Check the network connection.

Cause

  • A proxy server is set for the computer network.
  • The Winsock on the computer is abnormal.
  • The Windows defender firewall intercepts processes related to Huawei PC Manager.

Solution

Perform the following to troubleshoot:

  1. Disable the LAN proxy server and reset the Internet options. To do so, perform the following:
    1. Right-click the Windows Start menu and select Run from the shortcut menu.

    2. Enter inetcpl.cpl and press Enter.

    3. In Internet Options, go to Connections > LAN settings.

    4. Deselect Use a proxy server for your LAN and click OK.

    5. In Internet Options, click the Advanced tab. On the Advanced tab, click Restore advanced settings, and then click OK.

  1. Remember the network password and reset the network.
  2. Allow processes related to Huawei PC Manager to communicate with each other through Windows Defender.
    1. Exit third-party antivirus software, such as 360 Safeguard, Tencent PC Manager, and HUORONG.
    2. Click the Windows icon, go to All apps, click Windows Security to open it, and select Firewall & network protection on the left.

      Click here to open Windows Security.

    3. Click Allow an app through firewall. On the displayed screen, click Change Settings.
    4. Click Allow another app. In the displayed dialog box, click Browse, open the C:\PrograFiles\Huawei\BasicService\BasicService.exe file, click Add, and select Private and Public next to this process.

    5. Repeat step d to enable private and public network access for C:\Program Files\Huawei\PCManager\MateBookService.exe, C:\Program Files\Huawei\PCManager\MBAMessageCenter.exe, and C:\Program Files\Huawei\PCManager\PCManager.exe, and click OK.
  3. Uninstall and reinstall Huawei PC Manager. The procedure is as follows:
    1. On the computer, go to Control Panel > Programs > Uninstall a program. Right-click Huawei PC Manager and select Uninstall/Change from the shortcut menu to uninstall PC Manager and restart the computer.
    2. Download the Huawei PC Manager from the official website and reinstall it.

If the issue persists

If the issue persists, back up your data in advance, record your Office account, and use F10 to restore your computer to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. We will do our best to address your needs.

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