HUAWEIコンピュータがUSBデバイスを識別できません
適用製品:
PC,Desktop
適用製品:
| HUAWEIコンピュータがUSBデバイスを識別できません |
問題
HUAWEIコンピュータがUSBデバイスを識別できません。
原因
- サードパーティ製のウイルス対策ソフトウェアまたはマネージャーソフトウェアが、USBデバイスをブロックしています。
- USBシリアルポートドライバーに異常があるか、不安定です。
- USBポートが無効になっています。
- USBが選択的に一時停止され、設定に異常があります。
- USB接続に問題があります。
- USBデバイスの形式がWindowsシステムに対応していません。
- USBデバイスが配置されているドライブのパーティションファイルが破損しています。
解決方法
USBデバイスを別のコンピュータに接続し、デバイスの識別と使用が可能かどうかを確認します。可能でない場合は、USBデバイスが故障している可能性があります。USBデバイスのベンダーにお問い合わせください。可能な場合は、以下の手順を実行して原因を特定してください。
- サードパーティ製のウイルス対策ソフトウェアまたはマネージャーソフトウェアをアンインストールし、ファイアウォールを復元し、コンピュータを再起動します。
- サードパーティ製のウイルス対策ソフトウェアまたはマネージャーソフトウェアをアンインストールします。
- 検索バーに「appwiz.cpl」と入力して、プログラムと機能 を開きます。
- アンインストールしたいウイルス対策ソフトウェアまたはマネージャーソフトウェアを右クリックし、アンインストール/変更 をクリックします。
- ファイアウォールを復元します。検索ボックスに「コントロールパネル」と入力して コントロール パネル を開きます。 を選択し、プロンプトに従ってファイアウォールを復元します。
- サードパーティ製のウイルス対策ソフトウェアまたはマネージャーソフトウェアをアンインストールします。
- コンピュータから USB大容量記憶装置 をアンインストールし、USBデバイスを取り外して再度挿入します。
- Windowsアイコンを右クリックし、デバイス マネージャー を選択します。ユニバーサル シリアル バス コントローラー をクリックして展開し、USB大容量記憶装置 を右クリックして、ショートカットメニューから デバイスのアンインストール を選択します。
- 次の手順でシリアルポートドライバーをアンインストールして再インストールすることもできます。デバイス マネージャー を開き、ユニバーサル シリアル バス コントローラー をクリックして展開し、USB ルート ハブ(USB 3.0) を右クリックし、ショートカットメニューから デバイスのアンインストール を選択します。次に ユニバーサル シリアル バス コントローラー を再度右クリックし、ハードウェア変更のスキャン をクリックします。電源と外部デバイスをすべて切断します。電源ボタンを10秒間長押しして、コンピュータを再起動し、外部デバイスを再接続します。
- コンピュータのBIOS設定画面でUSBポートの設定を確認します。
- 起動中または再起動中に、F2キーを長押しするか連打して、BIOS設定画面を表示します。USB ポートの有効化 項目が存在するかどうかを確認します。
- 存在しない場合は、この手順をスキップしてください。
- USB ポートの有効化 が有効になっている場合は、この手順をスキップします。
- USB ポートの有効化 が無効になっている場合は、有効にします。
- BIOS設定画面で、F9キーを押してBIOSのデフォルト設定を復元し、OK をクリックし、F10キーを押して設定を保存します。USBポートは、初期のBIOS設定ではデフォルトで有効になっています。
- 起動中または再起動中に、F2キーを長押しするか連打して、BIOS設定画面を表示します。USB ポートの有効化 項目が存在するかどうかを確認します。
- USB のセレクティブ サスペンドの設定 を 無効 に設定します。設定するには、以下の手順を実行してください。
- タスクバーの検索ボックスに「コントロールパネル」と入力して コントロール パネル を開き、表示方法を 小さいアイコン に変更し、電源オプション を選択します。
- プラン設定の変更 をクリックします。
- 詳細な電源設定の変更 をクリックします。
- を展開し、バッテリ駆動 と 電源に接続 を両方とも 無効 に変更します。次に、OK をクリックします。
USB のセレクティブ サスペンドの設定 オプションは、一部のモデルでは利用できません。インテルの第11世代以降のプロセッサーでは、この機能がデフォルトで非表示になっているためです。設定を追加するには、レジストリを変更する必要があります。プロセスの詳細を以下に説明します。
- Windowsキーを押しながらRキーを押して、ファイル名を指定して実行 ウィンドウを開き、「Regedit」と入力してEnterキーを押します。
- Computer \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\2a737441-1930-4402-8d77-b2bebba308a3\48e6b7a6-50f5-4782-a5d4-53bb8f07e226の下で Attributes を探します。
- Attributes が存在しない場合は、左ペインでフォルダを右クリックして、Attributes という名前のDWORD(32ビット)値を作成します。Attributes をダブルクリックし、その値を 2 に変更します。
- で、バッテリ駆動 と 電源に接続 の両方を 無効 に設定します。次に、OK をクリックします。
- USBデバイスの接続状態を確認します。
- USBデバイスごとにポートサイズが異なる可能性があり、コンピュータに完全に接続できない場合があります。その場合は、USBデバイスを少し引き出すと、コンピュータに完全に接続できます。USBデバイスのサイズが合わない場合は、この方法をお試しください。
- 外付けデバイスがコンピュータに正しく接続されていない場合、コンピュータが反応しないことがあります。これを解決するには、デバイスをコンピュータに再度接続して、この問題が解決するかどうか確認します。または、デバイスをコンピュータの別のUSBポートに接続します。外付けデバイスの一部のUSBポートのサイズが標準的なものではなく、コンピュータのUSBポートに適合しない場合があります。
- ポータブルハードディスクを使用している場合は、ドッキングステーションを電源ケーブルに接続します。さらにポータブルハードディスクをドッキングステーションに接続して、問題の原因が電源によるものかどうかを確認します。
- 厳しい環境やホットスワップ運用中のエラー、耐用年数を超えた読み書き動作によって、USBデバイスが回復不能な損傷を受けている可能性があります。その結果、USBデバイスの安定性に影響が生じ、コンピュータがUSBデバイスを認識できない可能性があります。この場合は、新しいUSBデバイスを使用することをお勧めします。
- ファイルまたはディレクトリが破損しているかどうかを確認し、修復します。
- タスクバーの検索ボックスに「ファイルエクスプローラー」と入力して、エクスプローラーを開きます。ドライブレターをダブルクリックします。ファイルまたはディレクトリが破損していることを示すメッセージが表示されます。OK をクリックします。
- タスクバーの検索ボックスに「cmd」と入力し、コマンド プロンプト を右クリックして、ショートカットメニューから 管理者として実行 を選択します。
- ドライブレターは G: とします。chkdsk g:/f コマンドを入力し、Enterキーを押します。チェックが完了したら、ハードディスクの使用を続行できます。
- その他の設定をチェックします。
- USBデバイスのパーティションを右クリックし、ショートカットメニューから プロパティ を選択します。
- ツール タブをクリックし、チェック をクリックします。
- 2つのオプションを選択し、開始 をクリックして次の手順に進みます。
- チェックの結果が表示されたら、ウィンドウを閉じます。
- チェック中に修復可能なパーティションエラーがあれば、システムが自動的に修復します。
このケースは、USBデバイスをダブルクリックしても開くことができないものの、右クリックするとプロパティ機能が正常である場合に適用されます。
- USBデバイスをフォーマットします。
USBデバイスをフォーマットすると、データが失われます。データの損失を防ぐには、デバイスをリセットする前にデバイス上のデータをバックアップしてください。
- タスクバーの検索ボックスに「ファイルエクスプローラー」と入力して、エクスプローラーを開きます。ドライブレターを右クリックし、ショートカットメニューから フォーマット を選択します。
- デフォルト設定を変えず、開始 をクリックして次の手順に進みます。
- フォーマットが完了したことを示すダイアログボックスが表示されるのを待ちます。
問題が解決しない場合
問題が解決しない場合は、事前にデータをバックアップし、Officeアカウントを記録し、F10キーを使用してコンピュータを初期化します。それでも問題が解決しない場合は、ご利用のデバイスと購入証明書を持参し、正規のHuaweiカスタマーサービスセンターにご相談ください。お客様のご要望にお応えできるよう、最善を尽くします。
ご意見ありがとうございます