My HUAWEI computer cannot connect to a Wi-Fi network

Applicable products: PC,Desktop
Applicable products:
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My HUAWEI computer cannot connect to a Wi-Fi network

Problem

The computer fails to connect to a Wi-Fi hotspot or cannot connect to the Internet.

Cause

  • The router or network environment is abnormal.
  • The network configuration of the computer is abnormal.
  • Some network system parameters may have been tampered with due to software conflicts or viruses.
  • The network adapter driver version of the computer is too early with unstable performance, the network adapter driver is lost, or an unofficial driver has been installed.

Solution

If the network icon is unavailable in the lower right corner of the computer, refer to The network icon on the taskbar of my HUAWEI computer is missing to resolve this issue.

  1. Connect to another network and check the router settings.
    • Connect the device to another network or connect it to your phone's mobile data hotspot. Try connecting to multiple networks when necessary.
    • If the computer can connect to other networks and can access the Internet, the computer is normal and the issue may be caused by router network restrictions. In this case, perform the following steps to check the router settings.
      1. Remove the computer from the blocklist device list through the router app or the web management page.
      2. Power off the router and optical modem, and wait for 5 to 10 minutes before powering on and restarting them again.
      3. If the issue persists, restore the router to its factory settings and reconfigure it.

        The methods of setting the blocklist, restoring factory settings, and reconfiguring the router vary depending on the router brand. If you have any question when configuring your router, contact the router vendor for assistance.

  2. Remember the network password and reset the network settings of the computer.
  3. Go to Settings > Network & internet > Wi-Fi and disable Random hardware addresses.

    Click to go to Network & internet

  4. Disable and then restart the network adapter driver. If the issue remains, try uninstalling and reinstalling the latest network adapter driver.
    1. To disable and then restart the network adapter driver, perform the following steps.
      1. Press Win+X to open Device Manager.

      2. Click Network adapters and select the network adapter driver based on the processor type. (Intel(R) Wireless AC 9560 is used as an example.)
         
        • Intel network adapter driver: Intel(R) Wireless-AC 9560 or Intel(R) Wi-Fi 6 AX2**.
        • AMD network adapter driver: Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC or Intel(R) Wi-Fi 6 AX2**.
        • HUAWEI MateBook E Go network adapter driver: Qualcomm QCA639x Wi-Fi 6 Dual Band Simultaneous (DBS) Network Adapter or Qualcomm WCN685x Wi-Fi 6E Dual Band Simultaneous (DBS) WiFiCx Network Adapter.

      3. Right-click the corresponding network adapter driver and select Disable device. After the network adapter driver is disabled, restart the computer.

      4. Right-click the network adapter driver again and select Enable device.

    2. If the issue persists, uninstall and reinstall the Wi-Fi driver. To do so, perform the following:

      [Prerequisite]

      • Ensure that the computer can access the Internet through a wired network or use USB tethering with an Android phone/tablet. Use USB tethering: Connect an Android phone to the computer using a USB cable, go to the phone's Settings > Personal hotspot, enable USB tethering, and wait until the network icon in the lower right corner of the computer changes to the computer icon. Open any website and check that you can access the Internet. Then uninstall and reinstall the network adapter driver.
      • If you cannot use USB tethering or connect your computer to a wired network, download the corresponding driver from the Huawei Consumer BG official website to a normal device, by referring to Installing a driver on a HUAWEI computer. Then send the driver to your computer using a USB flash drive, portable hard disk, or Bluetooth to install it on your computer.
      • Skip this step for MateBook E 2019 and MateBook E Go.
      1. Uninstall the Wi-Fi driver: Right-click the Start icon on the desktop and go to Device Manager > Open. Find Network adapters, right-click the network adapter driver as needed (for example, Intel(R) Wireless-AC 9560), and select Uninstall device. In the displayed dialog box, select Attempt to remove the driver for this device., and click Uninstall.

      2. Install the Wi-Fi driver: After the driver is uninstalled, restart the computer and connect it to a wired or wireless network. Open Huawei PC Manager, go to Optimization > Drivers, select the wireless network adapter as needed, and click UPDATE.

      3. After the Wi-Fi driver is updated, restart the computer.

If the issue persists

If the issue persists, back up your data, record your Office account that has been activated, and use F10 to restore your device to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.

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