The Wi-Fi icon on the taskbar of my HUAWEI computer is missing
The Wi-Fi icon on the taskbar of my HUAWEI computer is missing |
Problem
There is no Wi-Fi icon in the bottom-right corner on the taskbar of the computer.
Cause
- The registry files related to the Windows operating system and network are deleted or modified.
- The running status of the network adapter driver of the computer is abnormal.
- The WLAN AutoConfig service is disabled.
Solution
- Check whether the network icon is hidden.
The user interface varies depending on the operating system. The network icon on the taskbar in Windows 11 cannot be hidden.
- Right-click any blank area on the taskbar and choose Taskbar settings.
- Swipe down on the Taskbar screen to the Notification area, then click Turn system icons on or off.
- Find Network on the right of the page and ensure that the switch is enabled.
- Move the computer close to the router and set MIMO Power Save Mode of the W-Fi to No SMPS (involved when an Intel network adapter driver is used). The procedure is as follows:
- Press Win+X, select Device Manager, and double-click Network adapters.
- Right-click Intel(R) Wireless-AC 9560 or Intel(R) Wi-Fi 6 AX20* and go to . Click MIMO Power Save Mode, select No SMPS from the Value list on the right, and click OK.
Performing this step will disconnect the network. After the network is disconnected, reconnect to the network.
- You can use the CCleaner software to clear the registry. Download and install CCleaner Free from the official CCleaner website. After the installation is complete, open CCleaner, go to , choose whether to back up the registry, click Fix All Selected Issues, then restart your computer.
Refer to Backing up and restoring the registry data to back up the registry in advance and exercise caution during registry modification, so as to avoid risks caused by incorrect operations.
- Press Win+X to open Device Manager, click Network adapters, and check whether the network adapter driver of the computer is lost.
- Intel network adapter driver: Intel(R) Wireless-AC 9560 or Intel(R) Wi-Fi 6 AX2*1.
- AMD network adapter driver: Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC or Intel(R) Wi-Fi 6 AX201.
- HUAWEI MateBook E Go network adapter driver: Qualcomm QCA639x Wi-Fi 6 Dual Band Simultaneous (DBS) Network Adapter, or Qualcomm WCN685x Wi-Fi 6E Dual Band Simultaneous (DBS) WiFiCx Network Adapter.
- HUAWEI MateBook E 2019 network adapter driver: Qualcomm (R) Wi-Fi B/G/N/AC(2X2)SVc
- If the network adapter driver is lost, connect your computer to a wired network or use a USB cable to connect your Android phone/tablet to your computer, open any website after the network icon in the lower right corner of the desktop changes to the computer icon, to ensure that you can access the Internet, then open Huawei PC Manager and go to to install the driver.
- Use USB tethering: Connect an Android phone to the computer using a USB cable, go to the phone's USB tethering, and wait until the network icon in the lower right corner of the computer changes to the computer icon. Open any website and check that you can access the Internet. Then uninstall and reinstall the network adapter driver. , enable
- If the network adapter driver exists, perform the following steps to uninstall and reinstall the network adapter driver:
Skip this step for HUAWEI MateBook E 2019 and HUAWEI MateBook E Go.
- Right-click the Start icon on the desktop, select Device Manager, and find Network adapters. Right-click the network adapter driver as needed, right-click Uninstall Device, select Attempt to remove the driver for this device. in the displayed dialog box, and click Uninstall.
- After the uninstallation is complete, restart the computer, connect an Android phone/tablet to the computer using a USB cable, and make sure that the computer can access the Internet. Open Huawei PC Manager, go to , select the wireless network adapter as needed, and click UPDATE.
- After you have installed the driver, restart the computer.
- Re-enable WLAN AutoConfig by performing the following steps:
- Press Win+R to open the Run dialog box, enter services.msc, and click OK.
- In the Services window, find WLAN AutoConfig , right-click its startup type, and select Start.
If the issue persists
If the issue persists, back up your data, record your Office account that has been activated, and use F10 to restore your device to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.